hdu_problem_2058_The sum problem

题目大意:给定一个序列 1 , 2 , 3 , ⋯   , N 1,2,3,\cdots,N 1,2,3,,N然后给一个数字M,计算该序列的子序列中加起来等于M的情况并输出。
输入:N和M。
输出:输出一个区间,该区间包含的子序列之和等于M,每种情况最后加上一个空行
方法:直接暴力求解会超时QAQ,所以需要用等差数列求和公式

S n = d 2 n 2 + ( a 1 − d 2 ) n S_n = \frac{d}{2}n^2 +(a_1 - \frac{d}{2})n Sn=2dn2+(a12d)n 可以得到 a 1 = S n − n ( n − 1 ) 2 n a_1 = \frac{S_n-\frac{n(n-1)}{2}}{n} a1=nSn2n(n1)

每次只需要算出 a 1 a_1 a1然后再把 a 1 a_1 a1带入到公式中看是否相等就可以了,并且由等差数列公式可以知道 1 &lt; = n &lt; = 2 S n 1&lt;=n&lt;=\sqrt{2S_n} 1<=n<=2Sn

/*
*
*Problem Description
*Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
*
*
*Input
*Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
*
*
*Output
*For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
*
*
*Sample Input
*20 10
*50 30
*0 0
*
*
*Sample Output
*[1,4]
*[10,10]
*
*[4,8]
*[6,9]
*[9,11]
*[30,30]
*
*
*Author
*8600
*
*
*Source
*校庆杯Warm Up
*
*
*Recommend
*linle
*
*/
#include<iostream>
using namespace std;
int main() {
 int N, M, temp;
 while (cin >> N >> M) {
  if (N == 0 && M == 0) break;
  for (int i = sqrt(2 * M); i >= 1; --i) {
   temp = (M - (i - 1)*i / 2) / i;
   if (temp*i + (i - 1)*i / 2 == M) {
    printf("[%d,%d]\n", temp, temp + i - 1);
   }
  }
  cout << endl;
 }
 system("pause");
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值