poj_2506

Tiling

Time Limit: 1000MS Memory Limit: 65536K

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.
Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

解题思路:
这个问题是分支策略有关的问题。分支策略的基本思想是将一个规模为n的问题分解为k个规模较小的子问题,这些子问题互相独立且与原问题相同。递归地解这些子问题,然后将各子问题的解合并得到原问题的解。就这道题而言,算出这n中情况所对应的解的集合,计算公式为:B[i] = B[i-1] + B[i-2]*2 此处应注意的是,B数组所存放的数据为大整型数据,所以采用了Java给我们提供的的BigInteger类型,这也是此题采用Java编写的一个方便之处,相较于C语言来看,C语言并没有提供大整型数据类型,需要自己定义。

参考程序:

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        BigInteger[] Big = new BigInteger[251]; 
        Big[0] = BigInteger.valueOf(1);
        Big[1] = BigInteger.valueOf(1); 
        for(int i = 2;i<= 250;i++){
            Big[i] =Big[i-1].add(Big[i-2].multiply(BigInteger.valueOf(2)));
        }
        Scanner in = new Scanner(System.in);
        while(in.hasNext()){
        int n = in.nextInt();
        System.out.println(Big[n]);
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值