Ant Trip HDU - 3018(一笔画)

Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country.

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.
Output
For each test case ,output the least groups that needs to form to achieve their goal.
Sample Input
3 3
1 2
2 3
1 3

4 2
1 2
3 4
Sample Output
1
2

问题的关键是对于一幅图,最少需要几笔经过每一条边,并且每条边恰好只能走一次

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<set>
#include<vector>
#define N 100005
using namespace std;
vector<int> graph[N];
bool vis[N];
int n,m;
int num;
void dfs(int x)
{
    if(graph[x].size()&1)
        num++;
    for(int i=0;i<graph[x].size();i++)
    {
        int v=graph[x][i];
        if(vis[v])
            continue;
        vis[v]=true;
        dfs(v);
    }
}
int main()
{
    int x,y;
    while(scanf("%d%d",&n,&m)==2)
    {
        int ans=0;
        memset(vis,false,sizeof(vis));
        for(int i=1;i<=n;i++)
            graph[i].clear();
        while(m--)
        {
            scanf("%d%d",&x,&y);
            graph[x].push_back(y);
            graph[y].push_back(x);
        }

        for(int i=1;i<=n;i++)
            if(!vis[i])
            {
                if(graph[i].size()==0)
                    continue;
                num=0;
                vis[i]=true;
                dfs(i);
                if(num>0)
                ans+=num/2;
                else
                ans+=1;         
            }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值