Delay Constrained Maximum Capacity Path HDU - 1839(二分+最短路)

Consider an undirected graph with N vertices, numbered from 1 to N, and M edges. The vertex numbered with 1 corresponds to a mine from where some precious minerals are extracted. The vertex numbered with N corresponds to a minerals processing factory. Each edge has an associated travel time (in time units) and capacity (in units of minerals). It has been decided that the minerals which are extracted from the mine will be delivered to the factory using a single path. This path should have the highest capacity possible, in order to be able to transport simultaneously as many units of minerals as possible. The capacity of a path is equal to the smallest capacity of any of its edges. However, the minerals are very sensitive and, once extracted from the mine, they will start decomposing after T time units, unless they reach the factory within this time interval. Therefore, the total travel time of the chosen path (the sum of the travel times of its edges) should be less or equal to T.
Input
The first line of input contains an integer number X, representing the number of test cases to follow. The first line of each test case contains 3 integer numbers, separated by blanks: N (2 <= N <= 10.000), M (1 <= M <= 50.000) and T (1 <= T <= 500.000). Each of the next M lines will contain four integer numbers each, separated by blanks: A, B, C and D, meaning that there is an edge between vertices A and B, having capacity C (1 <= C <= 2.000.000.000) and the travel time D (1 <= D <= 50.000). A and B are different integers between 1 and N. There will exist at most one edge between any two vertices.
Output
For each of the X test cases, in the order given in the input, print one line containing the highest capacity of a path from the mine to the factory, considering the travel time constraint. There will always exist at least one path between the mine and the factory obbeying the travel time constraint.
Sample Input
2
2 1 10
1 2 13 10
4 4 20
1 2 1000 15
2 4 999 6
1 3 100 15
3 4 99 4
Sample Output
13
99

首先观察答案的给出都是在输入中的流量中给出的,那么我们其实可以枚举容量的,在给定容量下求最少需要的时间,那么发现这个时间可以当最短路来求,但是每个容量量都要枚举么,发现倘若一个容量满足条件,那么所有小于这个容量的值都满足条件,满足二分的向下包含条件,自然而然是二分了,难度不大,写一个check()函数就好

#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
#include<stack>
#include<iostream>
#include<queue>
#define INF 0x7fffffff
#define N 105
using namespace std;
int ca[50005];
int k;
int n,m,h;
struct node
{
    int x1,x2;
    int c,time;
}edge[50005];
vector<int>graph[10005];
queue<int> que;
int dis[10005];
bool inQ[10005];
bool check(int index)//实际上check的主体代码是spfa算法
{
    int cc=ca[index];
    for(int i=2;i<=n;i++)
        dis[i]=INF;
    dis[1]=0;
    que.push(1);
    inQ[1]=true;
    while(!que.empty())
    {
        int u=que.front();
        que.pop();
        inQ[u]=false;
        for(int i=0;i<graph[u].size();i++)
        {
            int ind=graph[u][i];
            if(cc>edge[ind].c)
                continue;
            int v=(u==edge[ind].x1?edge[ind].x2:edge[ind].x1);
            if(dis[v]>dis[u]+edge[ind].time)
            {
                dis[v]=dis[u]+edge[ind].time;
                if(!inQ[v])
                {
                    que.push(v);
                    inQ[v]=true;
                }
            }
        }
    }
    return dis[n]<=h;
}
int main()
{
    int t;
    scanf("%d",&t);
    int x,y,c,time;
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&h);
        k=0;
        for(int i=1;i<=n;i++)
            graph[i].clear();
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d%d",&x,&y,&c,&time);
            edge[i].x1=x,edge[i].x2=y,edge[i].c=c,edge[i].time=time;
            graph[x].push_back(i);
            graph[y].push_back(i);
            ca[k++]=c;
        }
        sort(ca,ca+k);
        int num=unique(ca,ca+k)-ca;
        int l=0,r=num-1;
        int mid;

        while(l<=r)
        {
            mid=(l+r)>>1;
            if(check(mid))
                l=mid+1;
            else
                r=mid-1;
        }
        printf("%d\n",ca[r]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值