GCD HDU - 5726 (ST算法+二分)

Give you a sequence of N(N≤100,000)integers : a1,...,an(0<ai1000,000,000) . There are Q(Q100,000) queries. For each query l,rl,r you have to calculate gcd(al,,al+1,...,ar) and count the number of pairs (l',r')(1l<rN) such that gcd(al',al'+1,...,ar') equal gcd(al,al+1,...,ar) .
Input
The first line of input contains a number T, which stands for the number of test cases you need to solve.

The first line of each case contains a number NN, denoting the number of integers.

The second line contains NN integers, a1,...,an(0<ai1000,000,000) .

The third line contains a number Q, denoting the number of queries.

For the next Q lines, i-th line contains two number , stand for the li,rili,ri, stand for the i-th queries.
Output
For each case, you need to output “Case #:t” at the beginning.(with quotes, tt means the number of the test case, begin from 1).

For each query, you need to output the two numbers in a line. The first number stands for gcd(al,al+1,...,ar) and the second number stands for the number of pairs (l',r') such that gcd(al',al'+1,...,ar') equal gcd(al,al+1,...,ar) .
Sample Input
1
5
1 2 4 6 7
4
1 5
2 4
3 4
4 4
Sample Output
Case #1:
1 8
2 4
2 4
6 1

想到lST了,但是第二步统计数量没想好。

#include<cstdio>
#include<iostream>
#include<queue>
#include<cstring>
#include<vector>
#include<algorithm>
#include<cmath>
#include<map>
#define N 100005
using namespace std;
int dp[N][18];
int n;
int gcd(int a,int b)
{
    return a%b==0?b:gcd(b,a%b);
}
void RMQ()
{
    int cnt=ceil(log(n*1.0)/log(2.0));

    for(int i=1;i<=cnt;i++)
    {
        for(int j=1;j<=n;j++)
        {
            dp[j][i]=dp[j][i-1];
            if(j+(1<<(i-1))<=n)
                dp[j][i]=gcd(dp[j][i],dp[j+(1<<(i-1))][i-1]);
        }
    }
}
int getGCD(int l,int r)
{
    int cnt=(int)log2((double)(r-l+1));
    return gcd(dp[l][cnt],dp[r-(1<<cnt)+1][cnt]);
}
 map<int,long long> mp;
void init()
{
    mp.clear();
    for(int i=1;i<=n;i++)
    {
        int g=dp[i][0],j=i;
        while(j<=n)
        {
            int l=j,r=n;
            while(l<r)
            {
                int mid=(l+r+1)>>1;
                if(getGCD(i,mid)==g) l=mid;
                else r=mid-1;
            }
            mp[g]+=l-j+1;
            j=l+1;
            g=getGCD(i,j);
        }
    }
}
int main()
{
    //cout<<log2(100000);
    int t;
    int l,r;
    scanf("%d",&t);
    int ca=1;
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&dp[i][0]);
        RMQ();
        init();
        //cout<<"jaja";
        int q;
        scanf("%d",&q);
        printf("Case #%d:\n",ca++);
        while(q--)
        {
            scanf("%d%d",&l,&r);
            int gcdd=getGCD(l,r);
            printf("%d %lld\n",gcdd,mp[gcdd]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值