Car HDU - 5935(???)

Ruins is driving a car to participating in a programming contest. As on a very tight schedule, he will drive the car without any slow down, so the speed of the car is non-decrease real number.

Of course, his speeding caught the attention of the traffic police. Police record N positions of Ruins without time mark, the only thing they know is every position is recorded at an integer time point and Ruins started at 0.

Now they want to know the minimum time that Ruins used to pass the last position.
Input
First line contains an integer T, which indicates the number of test cases.

Every test case begins with an integers N, which is the number of the recorded positions.

The second line contains N numbers a1, a2, ⋯⋯, aN, indicating the recorded positions.

Limits
1T100
1N105
0<ai109
ai<ai+1
Output
For every test case, you should output ‘Case #x: y’, where x indicates the case number and counts from 1 and y is the minimum time.
Sample Input
1
3
6 11 21
Sample Output
Case #1: 4
这题我只能说没看懂,真的读不懂…………………………………………
简单题

#include<cstdio>
#include<algorithm>
#include<cstring>
#define N 2005
#define INF 0x3f3f3f3f
typedef long long ll;
using namespace std;
int a[100005];
int n;
int main()
{
    int t;
    int cal=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",a+i);

        for(int i=n;i>=1;i--)
            a[i]-=a[i-1];
        long long ans=1;
        long long temp=1;
        long long get;
        for(int i=n-1;i>=1;i--)
        {
            get=(a[i]*temp/a[i+1]);
            if((a[i]*temp)%a[i+1])
                get++;
            ans+=get;
            temp=get;
        }
        printf("Case #%d: %lld\n",cal++,ans);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值