(pat)A1014. Waiting in Line

4 篇文章 0 订阅

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

1.The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
2.Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
3.Customer[i] will take T[i] minutes to have his/her transaction processed.
4.The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output “Sorry” instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry

评价: 不会做,模拟题我不会,看到模拟我就想死。

#include<iostream>
#include<cstdio>
#include<map>
#include<vector>
#include<cstring>
#include<queue>
using namespace std;
int n,m,k,q;
int a[1005];
int ans[1005];
queue<int> que[25];
int main()
{
    cin>>n>>m>>k>>q;
    for(int i=1;i<=k;i++)
        cin>>a[i];
    int sum=0;
    int cur=1;
    for(int time=0;time<540;time++)
    {
        for(int i=0;i<n;i++)
        {
            if(!que[i].empty())
            {
                int now=que[i].front();
                if(time==ans[now])
                {
                    que[i].pop();
                    sum--;
                    if(!que[i].empty())
                        ans[que[i].front()]=time+a[que[i].front()];
                }
            }
        }//查看这个时间点,那些人完成了业务,然后出队,并更新下一个人的完成的时间(如果有下一个人)
        while(sum<n*m&&cur<=k)
        {
            int minn=0;
            for(int i=0;i<n;i++)
                if(que[minn].size()>que[i].size())
                    minn=i;
            if(que[minn].empty())
            {
                ans[cur]=time+a[cur];
                que[minn].push(cur++);
                sum++;
            }
            else
                if(que[minn].size()<m)
                    que[minn].push(cur++),sum++;
        }//入队
    }
    int x;
    while(q--)
    {
        cin>>x;
        if(!ans[x])
            cout<<"Sorry"<<endl;
        else
        {
            int h=8+ans[x]/60;
            int m=ans[x]%60;
            printf("%02d:%02d\n",h,m);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值