PAT-A1014 Waiting in Line (30)

时间限制: 400 ms 内存限制: 64 MB 代码长度限制: 16 KB

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
Customer[i] will take T[i] minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output “Sorry” instead.

Sample Input

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output

08:07
08:06
08:10
17:00
Sorry

题目很简单,30分水题
大意是K个人早上8:00来排队,8点时前N个开始办业务,前N*M个顺次划进黄线内,黄线外的等着
每一个进入黄线的客户总是选择人数最少的窗口排队,如果出现人数一样的那么选窗口ID小的
后面跟Q个查询,每个查询输出其办完业务的时间=办业务所用时长+队列前面的人办完业务的时间
如果前面的人超过17:00还没办完业务那么后面的人输出sorry(前面的人只要在17:00前开始办业务,即使办完的时间在17:00以后,也应输出相应的时间)

思路

定义结构体类型存储客户的服务时长stime,完成时间ftime,窗口ID wid(1~N)
定义数组wftime表示每个窗口最后一个人的完成时间
注意到客户进入黄线时,其办完业务的时间也就确定了,因此使用priority_queue作为黄线区,每个客户进入黄线时计算出完成时间ftime,重载运算符”<”首先选择ftime最小的如果ftime相同选择wid最小的(注:优先队列默认是大顶堆,返回a>b表示a的值比b小,优先弹出a) 当客户数小于等于N*M时,依次进入每个队列并计算ftime,更新wftime;当客户数大于N*M时,从优先队列中弹出一个客户,新来的客户继承其窗口ID,计算ftime更新wftime即可
最后判断每个查询的开始时间 ftime - stime + 8:00是否早于17:00,输出相应时间或sorry

#include <cstdio>
#include <queue>
using namespace std;
const int MAXK=1010;
const int ONTIME=8*60;
const int OFFTIME=17*60;

int N,M,K,Q,C;
int wftime[21]={0};
struct node{
    int stime,ftime,wid;
    friend bool operator <(const node&a,const node&b){
        if(a.ftime!=b.ftime) return a.ftime>b.ftime;
        return a.wid>b.wid;
    }
}customer[MAXK],cid;
priority_queue<node> q;
void printtime(int ftime,int stime){
    if(ftime-stime+ONTIME>=OFFTIME) printf("Sorry\n");
    else printf("%02d:%02d\n",(ftime+ONTIME)/60,(ftime+ONTIME)%60);
}
int main()
{
    int query,t,winid;
    scanf("%d%d%d%d",&N,&M,&K,&Q);
    C=N*M;
    for(int i=1;i<=K;++i){
        scanf("%d",&t);
        customer[i].stime=t;
        if(q.size()<C){
            winid=customer[i].wid=(i-1)%N+1;
        }else{
            cid=q.top();
            q.pop();
            winid=customer[i].wid=cid.wid;
        }
        customer[i].ftime=t+wftime[winid];
        wftime[winid]=customer[i].ftime;
        q.push(customer[i]);
    }
    for(int i=0;i<Q;++i){
        scanf("%d",&query);
        printtime(customer[query].ftime,customer[query].stime);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值