(pat)A1107. Social Clusters

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A “social cluster” is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki: hi[1] hi[2] … hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1

评价:希望最后一道30分我也可以遇到这么简单题,只是我没看懂….

代码:

#include<iostream>
#include<cstdio>
#include<vector>
#include<stack>
#include<algorithm>
#include<cstring> 
using namespace std;
int n; 
int  show[1005];
int pre[1005];
int qty[1005];
void init(int x)
{
    for(int i=1;i<=x;i++)
        pre[i]=i,qty[i]=1;
}
int findd(int x)
{
    return pre[x]==x?x:pre[x]=findd(pre[x]);
}
int ans[1005];
bool cmp(int x,int y)
{
    return x>y;
}
int main()
{
    cin>>n;
    int num ,x;
    init(n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d:",&num);
        while(num--)
        {
            cin>>x;
            if(!show[x])
                show[x]=i;
            else
            {
                int xx=findd(show[x]);
                int yy=findd(i);
                if(xx!=yy)
                {
                    pre[xx]=yy;
                    qty[yy]+=qty[xx];   
                } 
            }
        }
    }
    int total=0;
    for(int i=1;i<=n;i++)
        if(pre[i]==i)
            ans[total++]=qty[i];

    cout<<total<<endl;
    sort(ans,ans+n,cmp);
    for(int i=0;i<total-1;i++)
        cout<<ans[i]<<" ";
    cout<<ans[total-1];
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值