(pat)A1127. ZigZagging on a Tree

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
这里写图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15

评价:直接模拟就可以啦
代码

#include<iostream>
#include<cstdio>
#include<vector>
#include<stack>
#include<algorithm>
#include<cstring> 
#include<queue>
using namespace std;
int n;
int in[35];
int post[35];
struct node
{
    int data;
    node *l;
    node *r;
    char sign;
};
node* root;
node* dfs(int l,int r,int L,int R)
{
    if(l>r)
        return NULL;
    node *p=new node;
    p->data=post[R];
    //cout<<post[R]<<endl;
    int mid;
    for(mid=l;mid<=r;mid++)
        if(in[mid]==post[R])
            break;
    p->l=dfs(l,mid-1,L,mid-1-l+L);
    p->r=dfs(mid+1,r,mid-r+R,R-1);
    return p; 
}
int ans[35];
char flag[35];
int cnt=0;
void bfs()
{
    queue<node*> que;
    que.push(root);
    root->sign=false;
    while(!que.empty())
    {
        node * temp=que.front();que.pop();
        ans[cnt]=temp->data;
        flag[cnt++]=temp->sign;
        //cout<<temp->l<<endl;
        if(temp->l!=NULL)
        {
            temp->l->sign=temp->sign^1;
            que.push(temp->l);
        }
        if(temp->r!=NULL)
        {
            temp->r->sign=temp->sign^1;
            que.push(temp->r);
        }
    }
}
int main()
{
    cin>>n;
    for(int i=0;i<n;i++)
        cin>>in[i];
    for(int i=0;i<n;i++)
        cin>>post[i];
    root=dfs(0,n-1,0,n-1);
    bfs();
    cout<<ans[0];
    stack<int> st;
    for(int i=1;i<cnt;i++)
    {
        if(!flag[i])//如果为0则是反序,入栈
            st.push(ans[i]);
        else
        {
            while(!st.empty())
            {
                cout<<" "<<st.top();
                st.pop();
            }
            cout<<" "<<ans[i];
        }
    }
    while(!st.empty())
    {
        cout<<" "<<st.top();
        st.pop();
    }   
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值