PAT A1127. ZigZagging on a Tree (30)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15

#include <cstdio>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
const int Max = 40;
int n;
struct node{
	int data,height;
	node *lchild,*rchild;
};
vector<int> S[Max];
int post[Max]={0},in[Max]={0};
node* BuildTree(int postL,int postR,int inL,int inR,int h)
{
	if(postL>postR)
	{
		return NULL;
	}
	node* root = new node;
	root->data=post[postR];
	root->height=h;
	int k;
	for(k=inL;k<=inR;k++)
	{
		if(in[k]==post[postR])
		{
			break;
		}
	}
	int numL=k-inL;
	root->lchild=BuildTree(postL,postL+numL-1,inL,inL+numL-1,h+1);
	root->rchild=BuildTree(postL+numL,postR-1,inL+numL+1,inR,h+1);
	return root;
}
int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&in[i]);
	}
	for(int i=0;i<n;i++)
	{
		scanf("%d",&post[i]);
	}
	node *root= new node;
	root=BuildTree(0,n-1,0,n-1,1);
	queue<node*>q;
	q.push(root);
	int max=0;
	while(!q.empty())
	{
		node* p= new node;
		p=q.front();
		q.pop();
		S[p->height].push_back(p->data);
		if(p->height>max) max=p->height;
		if(p->lchild!=NULL) q.push(p->lchild);
		if(p->rchild!=NULL) q.push(p->rchild);
	}
    for(int i=1;i<=max;i++)
	{
		if(i%2==0)
		{
			for(int j=0;j<S[i].size();j++)
			{
				printf("%d",S[i][j]);
				if(i==max&&j==S[i].size()-1)
					printf("\n");
				else printf(" ");
			}
			
		}
		else 
		{
			
			for(int j=S[i].size()-1;j>=0;j--)
			{
				printf("%d",S[i][j]);
				if(i==max&&j==0)
					printf("\n");
				else printf(" ");
			}
		}
	}
	system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值