Parity game POJ - 1733 (离散化+种类并查集)

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend’s answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.
Input
The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either even' orodd’ (the answer, i.e. the parity of the number of ones in the chosen subsequence, where even' means an even number of ones andodd’ means an odd number).
Output
There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.
Sample Input
10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd
Sample Output
3
题意就是有有一串01数列, 每次有一个01序列,然后又m个描述,表明l到r里面1的数列是偶数还是奇数,当到第几个描述是,与前面的描述不符。
思路:用并查集的思想。同事用一个数组d【x】表示x和他的pre的之间的关系,如果是0,表示是同个类型,如果是1表示是不同的类型。但是n可以达到10的9次方,但是询问只有10000个最多,所以离散化一下即可。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#define maxx 10005
using namespace std;
int n;
int id[maxx<<1];
int cnt;
struct node
{
    int l,r;
    int op;
}query[maxx];
int num;
int get(int x)
{
    return lower_bound(id,id+num,x)-id+1;
}
int pre[maxx<<1];
int d[maxx<<1];
void init()
{
    for(int i=1;i<=num;i++)
        pre[i]=i;
    memset(d,0,sizeof(d));
}
int findd(int x)
{
    if(pre[x]==x)
        return x;

    int root=findd(pre[x]);
    d[x]^=d[pre[x]];
    return pre[x]=root;
}
int main()
{
    int n;
    cin>>n;
    int m;
    cin>>m;
    char s[10];
    cnt=0;
    for(int i=0;i<m;i++)
    {
        scanf("%d%d%s",&query[i].l,&query[i].r,s);
        query[i].l--;
        id[cnt++]=query[i].l;
        id[cnt++]=query[i].r;
        if(s[0]=='e')
            query[i].op=0;
        else
            query[i].op=1;
    }
    sort(id,id+cnt);
    num=unique(id,id+cnt)-id;
    init();
    int countt=0;
    for(int i=0;i<m;i++)
    {
        int l=get(query[i].l);
        int r=get(query[i].r);
        int ll=findd(l);
        int rr=findd(r);
        if(ll==rr)
        {
            if((d[l]^d[r])!=query[i].op)
                break;
        }
        else
        {
            pre[ll]=rr;
            d[ll]=d[l]^d[r]^query[i].op;
        }
        countt++;
    }
    cout<<countt<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值