Parity game

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend’s answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.
Input
The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either even' orodd’ (the answer, i.e. the parity of the number of ones in the chosen subsequence, where even' means an even number of ones andodd’ means an odd number).
Output
There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.
Sample Input
10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd
Sample Output
3
给了n个描述,从l到r区间内数的和是奇数还是偶数,给出第一个矛盾是哪句话。如果没有矛盾,就是n;

看了数据范围就是要炸,可以用map映射,因为输入的描述并不多。
然后输入l,r。就可以用食物链的处理办法,写出儿子和祖先的关系。
这里区间要用左开右闭,否则当区间右重合时,会重复计算。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 1005;
map<int, int>p;
map<int, int>pp;
int find(int x)
{
    if (x != p[x])
    {
        int fx = find(p[x]);
        if (pp[x] == pp[p[x]])
            pp[x] = 0;
        else pp[x] = 1;
        p[x] = fx;
    }
    return p[x];
}
int main()
{
#ifdef LOCAL
    freopen("C:\\Users\\ΡΡ\\Desktop\\in.txt", "r", stdin);
    //freopen("C:\\Users\\ΡΡ\\Desktop\\out.txt","w",stdout);
#endif // LOCAL
    int len, n;
    scanf("%d%d", &len, &n);
    int ans = -1;
    for (int i = 1; i <= n; i++)
    {
        int x, y;
        char c[4];
        scanf("%d%d%s", &x, &y, c);
        if (ans != -1)continue;
        x--;
        if (!p.count(x))
        {
            p[x] = x; pp[x] = 0;
        }
        if (!p.count(y))
        {
            p[y] = y; pp[y] = 0;
        }
        int fx = find(x);
        int fy = find(y);
        if (fx == fy)
        {
            if (pp[x] == pp[y] && c[0] == 'e')continue;
            else if (pp[x] != pp[y] && c[0] == 'o')continue;
            else ans = i - 1;
        }
        else
        {
            p[fx] = fy;
            if (c[0] == 'o')
                pp[fx] = (2 - pp[x] + 1 + pp[y]) % 2;
            else if (c[0] == 'e')
                pp[fx] = (2 - pp[x] + 2 + pp[y]) % 2;
        }
    }
    if (ans != -1)
        printf("%d\n", ans);
    else printf("%d\n", n);
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值