HDU 1385 Minimum Transport Cost(Floyd+路径输出)

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11367    Accepted Submission(s): 3176


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
预备知识:
1.(Floyd)这里就不多说了
2.Floyd路径输出:
1.首先初始化对于所有的可联通的i j 两点path[i][j]=i;
2.如果满足map[i][j]>map[i][k]+map[k][j],则pata[i][j]=path[i][k];
3.遍历输出
例:1-->2-->3 3-->4-->5
dp[1][3]=dp[1][2]=2;
dp[3][5]=dp[3][4]=4;
d[1][5]=dp[1][3]=2;
dp[1][5]=2;
dp[2][5]=dp[2][3]=3;
dp[3][5]=4;
注意:本来以为直接遍历下来就是按照字典序排好的,但是发现wa所以仍然需要字典序的判断,原因的话因为1-->5-->4-->8-->7-->6-->3 和1-->2-->10-->3的话若不判断字典序k==7时就结束了
不是输出1-->2-->10-->3而是1-->5-->4-->8-->7-->6-->3错误
#include <stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 0x00ffffff
int map[200][200];
int path[200][200];
int tax[200];
int main(int argc, char *argv[])
{
    int n;
    while(scanf("%d",&n),n)
    {
        memset(path,0,sizeof(path));
        int i,j,k;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%d",&map[i][j]);
                if(map[i][j]!=-1)
                path[i][j]=j;
                else
                map[i][j]=inf;
            }
        }
        for(i=1;i<=n;i++)
        scanf("%d",&tax[i]);
        for(k=1;k<=n;k++)
        {
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=n;j++)
                {
                    if(map[i][j]>map[i][k]+map[k][j]+tax[k])
                    {                                        
                        path[i][j]=path[i][k];
                        map[i][j]=map[i][k]+map[k][j]+tax[k];
                    }
                    else if(map[i][j]==(map[i][k]+map[k][j]+tax[k]))
                    {
                    	if(path[i][j]>path[i][k])
                        {
						path[i][j]=path[i][k];
                        map[i][j]=map[i][k]+map[k][j]+tax[k];
                        }
				    } 
                }
            }
        }
        int start,end;
        while(scanf("%d %d",&start,&end)!=EOF)
        {
            if(start==-1&&end==-1)
            break;
            printf("From %d to %d :\n",start,end);
            printf("Path: %d",start);
            int next=start;
            while(next!=end)
            {
            printf("-->%d",path[next][end]);
            next=path[next][end];
            }    
            printf("\n",end);        
            printf("Total cost : %d\n\n",map[start][end]);
        }
    }
    return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值