HDU 2446 Shell Pyramid(二分查找+数学)

Problem Description
In the 17th century, with thunderous noise, dense smoke and blazing fire, battles on the sea were just the same as those in the modern times. But at that time, the cannon ,were extremely simple. It was just like an iron cylinder, with its rearward end sealed and forward end open. There was a small hole at the rearward end of it, which was used to install the fuse. The cannons on the warships were put on small vehicles which had four wheels and the shells were iron spheres with gunpowder in them.
At that time, it was said that there was an intelligent captain, who was also a mathematician amateur. He liked to connect everything him met to mathematics. Before every battle, he often ordered the soldiers to put the shells on the deck and make those shells to form shell pyramids.
Now let's suppose that a shell pyramid has four layers, and there will be a sequence of ordinal numbers in every layer. They are as the following figure:



In the figure, they are the first layer, the second layer, the third layer and the fourth layer respectively from the left to the right.
In the first layer, there is just 1 shell, and its ordinal number is 1. In the second layer, there are 3 shells, and their ordinal numbers are 1, 2, and 3. In the third layer, there are 6 shells, and their ordinal numbers are 1, 2, 3, 4, 5, and 6. In the fourth layer, there are 10 shells, and their ordinal numbers are shown in the figure above.
There are also serial numbers for the whole shell pyramid. For example, the serial number for the third shell in the second layer is 4, the serial number for the fifth shell in the third layer is 9, and the serial number for the ninth shell in the fourth layer is 19.
There is also a interrelated problem: If given one serial number s, then we can work out the s th shell is in what layer, what row and what column. Assume that the layer number is i, the row number is j and the column number is k, therefore, if s=19, then i=4, j=4 and k=3.
Now let us continue to tell about the story about the captain.
A battle was going to begin. The captain allotted the same amount of shells to every cannon. The shells were piled on the deck which formed the same shell pyramids by the cannon. While the enemy warships were near, the captain ordered to fire simultaneously. Thunderous sound then was heard. The captain listened carefully, then he knew that how many shells were used and how many were left. 
At the end of the battle, the captain won. During the break, he asked his subordinate a question: For a shell pyramid, if given the serial number s, how do you calculate the layer number i, the row number j and column number k? 
Input
First input a number n,repersent n cases.For each case there a shell pyramid which is big enough, a integer is given, and this integer is the serial number s(s<2^63). There are several test cases. Input is terminated by the end of file.
Output
For each case, output the corresponding layer number i, row number j and column number k.
Sample Input
  
  
2 19 75822050528572544
Sample Output
  
  
4 4 3 769099 111570 11179
Source

2008 Asia Regional Harbin

杭电OJ爆炸 没有验证代码正确性 可能数组会开小 但是思路正确

OJ上开1000001的数组过,开2000001的数组会MLE 不改了 警示一下

#include <stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
long long a[2000001]; 
long long sum[2000001];
int main(int argc, char *argv[])
{
	int i;
	a[1]=1;
	for(i=2;i<2000001;i++)//每堆各行的最大数 
	{
		a[i]=a[i-1]+i;
	}
	sum[1]=1;
	for(i=2;i<2000001;i++)//每堆的最大数 
	{
		sum[i]=sum[i-1]+a[i];
	}
	int t;
	scanf("%d",&t);
	while(t--)
	{
		long long num;
		scanf("%lld",&num);
		long long p=lower_bound(sum,sum+2000001,num)-sum;//p为第几堆 
		num-=sum[p-1];
		long long row=lower_bound(a,a+2000001,num)-a;//row第几行
		long long col=num-a[row-1];//col 第几个 
		printf("%lld %lld %lld\n",p,row,col); 
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值