HDU 1143 Tri Tiling (数学)

Tri Tiling

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 2
Problem Description
In how many ways can you tile a 3xn rectangle with 2x1 dominoes? Here is a sample tiling of a 3x12 rectangle.


 

Input
Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 ≤ n ≤ 30.
 

Output
For each test case, output one integer number giving the number of possible tilings.
 

Sample Input
  
  
2 8 12 -1
 

Sample Output
  
  
3 153 2131
 如题 n>=4时有两种大方法来拼
第一种:

f(n)=f(n-2)*3;


第二种:
f(n)=2*f(n-4)+2*f(n-6)+......2*f(2)+2*f(0)

所以总f(n)= f(n-2)*3+2*f(n-4)+2*f(n-6)+......2*f(2)+2*f(0);
f(n)-f(n-2)=4*f(n-4)-f(n-2);
#include <stdio.h>
int main(int argc, char *argv[])
{
	long long a[31]={0};
	a[0]=1;
	a[2]=3;
	int i;
	for(i=4;i<31;i++)
	{
		if(i%2==1)
		continue;
		a[i]=a[i-2]*4-a[i-4];
	} 
	int n;
	while(scanf("%d",&n),n!=-1)
	{
		printf("%lld\n",a[n]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值