HDU 3339 (dijkstra+0 1背包)

In Action

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6934    Accepted Submission(s): 2359


Problem Description

Since 1945, when the first nuclear bomb was exploded by the Manhattan Project team in the US, the number of nuclear weapons have soared across the globe.
Nowadays,the crazy boy in FZU named AekdyCoin possesses some nuclear weapons and wanna destroy our world. Fortunately, our mysterious spy-net has gotten his plan. Now, we need to stop it.
But the arduous task is obviously not easy. First of all, we know that the operating system of the nuclear weapon consists of some connected electric stations, which forms a huge and complex electric network. Every electric station has its power value. To start the nuclear weapon, it must cost half of the electric network's power. So first of all, we need to make more than half of the power diasbled. Our tanks are ready for our action in the base(ID is 0), and we must drive them on the road. As for a electric station, we control them if and only if our tanks stop there. 1 unit distance costs 1 unit oil. And we have enough tanks to use.
Now our commander wants to know the minimal oil cost in this action.
 

Input
The first line of the input contains a single integer T, specifying the number of testcase in the file.
For each case, first line is the integer n(1<= n<= 100), m(1<= m<= 10000), specifying the number of the stations(the IDs are 1,2,3...n), and the number of the roads between the station(bi-direction).
Then m lines follow, each line is interger st(0<= st<= n), ed(0<= ed<= n), dis(0<= dis<= 100), specifying the start point, end point, and the distance between.
Then n lines follow, each line is a interger pow(1<= pow<= 100), specifying the electric station's power by ID order.
 

Output
The minimal oil cost in this action.
If not exist print "impossible"(without quotes).
 

Sample Input
 
 
2 2 3 0 2 9 2 1 3 1 0 2 1 3 2 1 2 1 3 1 3
 

Sample Output
 
 
5 impossible
 

Author
Lost@HDU
 
注意:一个坦克只可以攻击一个村,之后需要重新从起点出发 先用最短路算出0点到各个点的距离,然后以距离为容量,各个村的能量为价值,就可以算出当前路程可以摧毁的最大能量
#include <stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0xfffffff
using namespace std;
int map[1001][1001];
int visit[1001];
int minload[1001];
int pows[1001];
int main(int argc, char *argv[])
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		
		int j,n,m,i;//n个村庄 m条路
		scanf("%d %d",&n,&m);
		for(i=0;i<=n;i++)
		{
			minload[i]=INF;
			visit[i]=1;	
			for(j=0;j<=n;j++)
			{
				map[i][j]=INF;	
			}
		}
		int a,b,c;
		while(m--)
		{
			scanf("%d %d %d",&a,&b,&c);
			map[a][b]=map[b][a]=min(map[a][b],c);		
		}
		minload[0]=0;
		visit[0]=0;
		int s=0;
		int chun,min1;
		for(i=0;i<n;i++)
		{
			min1=INF;	
			for(j=1;j<=n;j++)
			{
				if(map[s][j]!=INF)
				minload[j]=min(minload[j],minload[s]+map[s][j]);
				if(min1>minload[j]&&visit[j])
				{
					min1=minload[j];
					chun=j; 
				}	
			}
			if(min1==INF)
			{
				break;
			}
			s=chun;
			visit[s]=0;
		}
		int cnt=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&pows[i]);
			cnt+=pows[i];
		}
		int sum=0;
		for(i=1;i<=n;i++)
		{
			if(minload[i]!=INF)
			sum+=minload[i];	
		}
		int dp[10001]={0};
		for(i=1;i<=n;i++)
		{
			if(minload[i]!=INF)
			{	for(j=sum;j>=minload[i];j--)
				{
					dp[j]=max(dp[j],dp[j-minload[i]]+pows[i]);
				}
			}
		}
		bool judge=false;
		for(i=0;i<=sum;i++)
		{
			if(dp[i]>=cnt/2+1)
			{
				judge=true;
				printf("%d\n",i);	
				break;
			}
		}
		if(judge==false)
		{
			printf("impossible\n");
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值