主力队对抗赛 Sum of Different Primes

Sum of Different Primes

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 3   Accepted Submission(s) : 1
Problem Description
A positive integer may be expressed as a sum of different prime numbers (primes), in one way or another. Given two positive integers  n and  k, you should count the number of ways to express  n as a sum of  k different primes. Here, two ways are considered to be the same if they sum up the same set of the primes. For example, 8 can be expressed as 3 + 5 and 5 + 3 but the are not distinguished.

When n and k are 24 and 3 respectively, the answer is two because there are two sets {2, 3, 18} and {2, 5, 17} whose sums are equal to 24. There are not other sets of three primes that sum up to 24. For n = 24 and k = 2, the answer is three, because there are three sets {5, 19}, {7, 17} and {11, 13}. For n = 2 and k = 1, the answer is one, because there is only one set {2} whose sum is 2. For n = 1 and k = 1, the answer is zero. As 1 is not a prime, you shouldn锟斤拷t count {1}. For n = 4 and k = 2, the answer is zero, because there are no sets of two different primes whose sums are 4.

Your job is to write a program that reports the number of such ways for the given n and k.

Input

The input is a sequence of datasets followed by a line containing two zeros separated by a space. A dataset is a line containing two positive integers n and k separated by a space. You may assume that n 锟斤拷 1120 and k 锟斤拷 14.

Output

The output should be composed of lines, each corresponding to an input dataset. An output line should contain one non-negative integer indicating the number of the ways for n and k specified in the corresponding dataset. You may assume that it is less than 231.

Sample Input

24 3 
24 2 
2 1 
1 1 
4 2 
18 3 
17 1 
17 3 
17 4 
100 5 
1000 10 
1120 14 
0 0

Sample Output

2 
3 
1 
0 
0 
2 
1 
0 
1 
55 
200102899 
2079324314

 
二维母函数c1[num][len] len用来控制长度
#include <stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
int main(int argc, char *argv[])
{
	int n,len;
	int i,j;
	int c1[10001][20]; int c2[10001][20];
	int bit[200];
	bit[0]=2;
	int cnt=1;
	for(i=3;i<2000;i++)
	{
		int judge=false;
		for(j=2;j*j<=i;j++)
		{
			if(i%j==0)
			{
				judge=true;
				break;
			}	
		}
		if(!judge)bit[cnt++]=i;
	}
	
	while(scanf("%d %d",&n,&len)!=EOF)
	{
		memset(c1,0,sizeof(c1));
		memset(c2,0,sizeof(c2));
		c1[bit[0]][1]=1;			
		c1[0][0]=1;
		int k;
		int max1;
		for(i=0;i<200;i++)
		{
			if(bit[i]>n)
			{
				max1=i-1;
				break;	
			}
		}
	//	printf("%d %d\n",bit[max1],max1); 5 2
		for(k=1;k<=max1;k++)
		{
			for(i=0;i<=n;i++)
			{
				for(j=0;j+i<=n&&j<=bit[k];j+=bit[k])
				{
				//	printf("%d ",j);
					for(int q=0;q<=len;q++)
					{
						if(j==0)
						{
							c2[i+j][q]+=c1[i][q];
						}	
						else
						{
							c2[i+j][q+1]+=c1[i][q];
						}
					}						
				}
				
			}
			for(j=0;j<=n;j++)
				{
					for(int q=0;q<=len;q++)
					{
						c1[j][q]=c2[j][q];
						c2[j][q]=0;
					}
				}
		}
		printf("%d\n",c1[n][len]);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值