Binary String Matching

Binary String Matching

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 
代码如下:
1、
#include<iostream>
#include<sstream>
#include<string>
using namespace std;
char *c=NULL;
char *c1=NULL;
int count=0;
void cal(int len1,int len){//查找相等的个数 
	int index=0; 
	for(int i=0;i<len-len1+1;){
		for(int j=0;j<len1;){
			if(c1[j]==c[i]){
				if(j==len1-1){
					count++;
					i=i-j+1;
					break;
				}else{
					i++;j++;
				}
			}else{
				i=i-j+1; 
				break;
			}
		}
	} 
}
void tranform(string s,char *c){//将字符串转化成字符数组 
	stringstream ss;
	ss<<s;
	while(ss>>c);
}
int main(){
	int n;
	string s,s1;
	cin>>n;
	while(n--){
		count=0;
		cin>>s1>>s;
		int len=s.length();
		c=new char[len];
		int len1=s1.length();
		c1=new char[len1];
		tranform(s,c);
		tranform(s1,c1);
		cal(len1,len);
		cout<<count<<endl;
		delete[]c;
		delete[]c1;
	}
	return 0;
}
2、
#include <iostream>
#include <string>
using namespace std;
int main()
{
	int n;
	cin>>n;
	while(n--){
		int sum=0;
		string a,b;
		cin>>a>>b;
		for(int i=0;i<b.length()-a.length()+1;i++)
			if(b.compare(i,a.length(), a)==0 )
				sum++;
		cout <<sum<<endl;	   
	} 
	return 0;
}

(全文完)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值