51Nod - 1011 最大公约数(三种方法)

输入2个正整数A,B,求A与B的最大公约数。

Input

2个数A,B,中间用空格隔开。(1<= A,B <= 10^9)

Output

输出A与B的最大公约数。

Sample Input
 30 105
Sample Output
 15

这个题很简单,弱弱我主要是想挂一下模板。。。(原理,辗转相除法)
代码1:

#include<iostream>
#define ll long long
using namespace std;
ll gcd(ll a,ll b)
{
	if(b==0) return a;
	else return gcd(b,a%b);
}
int main()
{
	ios::sync_with_stdio(false);
	int a,b;
	cin>>a>>b;
	cout<<gcd(a,b); 
	return 0;
}

代码2:

#include<iostream>
#include<algorithm> //__gcd函数的头文件
#define ll long long
using namespace std;
int main() 
{
    ll a,b;
    cin>>a>>b;
    cout<<__gcd(a,b)<<endl;
    return 0;
}

代码3:

#include<iostream>
#define ll long long
using namespace std;
int main()
{
	ios::sync_with_stdio(false);
	ll a,b;
	cin>>a>>b;
	while(b!=0)
	{
		ll c=a%b;
		a=b;
		b=c;
	}
        cout<<a;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值