Mountain Subsequences(dp问题)

题目描述

Coco is a beautiful ACMer girl living in a very beautiful mountain. There are many trees and flowers on the mountain, and there are many animals and birds also. Coco like the mountain so much that she now name some letter sequences as Mountain Subsequences.

A Mountain Subsequence is defined as following:

  1. If the length of the subsequence is n, there should be a max value letter, and the subsequence should like this, a1 < …< ai < ai+1 < Amax > aj > aj+1 > … > an
  2. It should have at least 3 elements, and in the left of the max value letter there should have at least one element, the same as in the right.
  3. The value of the letter is the ASCII value.

Given a letter sequence, Coco wants to know how many Mountain Subsequences exist.

输入

Input contains multiple test cases.
For each case there is a number n (1<= n <= 100000) which means the length of the letter sequence in the first line, and the next line contains the letter sequence.
Please note that the letter sequence only contain lowercase letters.

输出

For each case please output the number of the mountain subsequences module 2012.

样例输入
4
abca
样例输出
4
提示

The 4 mountain subsequences are:
aba, aca, bca, abca

思路

枚举每个字母是最中间的那个最大的字母,向两边分别找递减的子序列一共有多少个,求左右递减子序列的乘积,最终答案就是所有乘积之和

代码
#include<iostream>
#include<string>
#include<map>
#include<set>
//#include<unordered_map>
#include<queue>
#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
#include<iomanip>
#include<stack>
#include<cmath>
#include<fstream>
#define X first
#define Y second
#define best 131 
#define INF 0x3f3f3f3f
#define P pair<int,int>
#define ls p<<1
#define rs p<<1|1
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const double eps=1e-5;
const double pai=acos(-1.0);
const int N=1e5+10;
const int maxn=1e6+10;
char s[N];
int n,dp[N],a[N],l[N],r[N],mod=2012;
int main( )
{
    int n;
    while(~scanf("%d",&n))
    {
        scanf("%s",s);
        for(int i=0;i<n;i++) a[i]=s[i]-'a';
        memset(l,0,sizeof(l));
        memset(r,0,sizeof(r));
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<a[i];j++) l[i]=(l[i]+dp[j])%mod;
            //l[i]是求字母s[i]左边,结尾小于a[i]的子序列个数 
            dp[a[i]]=(dp[a[i]]+l[i]+1)%mod;
            // dp[a[i]]是求当前以a[i]为结尾的子序列的个数 
        }
        memset(dp,0,sizeof(dp));
        for(int i=n-1;i>=0;i--)
        {
            for(int j=0;j<a[i];j++) r[i]=(r[i]+dp[j])%mod;
            //r[i]是求字母s[i]右边,开头小于a[i]的子序列个数 
            dp[a[i]]=(dp[a[i]]+r[i]+1)%mod;// 同上 
        }
        int ans=0;
        for(int i=0;i<n;i++) ans=(ans+l[i]*r[i])%mod;
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值