山东省第四届ACM大学生程序设计竞赛 Mountain Subsequences dp

Mountain Subsequences

Time Limit: 1000MS Memory limit: 65536K

题目描述

Coco is a beautiful ACMer girl living in a very beautiful mountain. There are many trees and flowers on the mountain, and there are many animals and birds also. Coco like the mountain so much that she now name some letter sequences as Mountain Subsequences.

 

A Mountain Subsequence is defined as following:

1. If the length of the subsequence is n, there should be a max value letter, and the subsequence should like this, a1 < ...< ai < ai+1 < Amax > aj > aj+1 > ... > an

2. It should have at least 3 elements, and in the left of the max value letter there should have at least one element, the same as in the right.

3. The value of the letter is the ASCII value.

 

Given a letter sequence, Coco wants to know how many Mountain Subsequences exist.

输入

Input contains multiple test cases.

For each case there is a number n (1<= n <= 100000) which means the length of the letter sequence in the first line, and the next line contains the letter sequence.

Please note that the letter sequence only contain lowercase letters. 

输出

For each case please output the number of the mountain subsequences module 2012.

示例输入

4abca

示例输出

4

提示

The 4 mountain subsequences are:

aba, aca, bca, abca

来源

 2013年山东省第四届ACM大学生程序设计竞赛

示例程序


求凸子序列的个数

先求一遍每个点到当前的递增子序列个数

在求一遍每个点为起点到结束的递减子序列的个数

最后相乘就是答案

ACcode:

#include <map>  
#include <queue>  
#include <cmath>  
#include <cstdio>  
#include <cstring>  
#include <stdlib.h>  
#include <iostream>  
#include <algorithm>  
#define maxn 100100  
#define mod 2012  
using namespace std;  
int low[maxn],big[maxn],a[maxn],num[maxn];  
char mapp[maxn];  
void init(){  
    memset(low,0,sizeof(low));  
    memset(big,0,sizeof(big));  
    memset(num,0,sizeof(num));  
}  
int main(){  
    int n,ans;  
    while(~scanf("%d",&n)){  
        init();  
        scanf("%s",&mapp);  
        for(int i=0;i<n;++i)a[i]=mapp[i]-'a';  
        for(int i=0;i<n;++i){  
            for(int j=0;j<a[i];++j)  
             low[i]=(low[i]+num[j])%mod;  
            num[a[i]]=(num[a[i]]+low[i]+1)%mod;  
        }  
        /*for(int i=0;i<n;++i)cout<<num[i]<<' '; 
        cout<<'\12';*/  
        memset(num,0,sizeof(num));  
        for(int i=n-1;i>=0;--i){  
            for(int j=0;j<a[i];++j)  
             big[i]=(big[i]+num[j])%mod;  
            num[a[i]]=(num[a[i]]+big[i]+1)%mod;  
        }  
      /*  for(int i=0;i<n;++i)cout<<num[i]<<' '; 
        cout<<'\12'; 
        for(int i=0;i<n;++i)cout<<low[i]<<" "; 
        cout<<'\12'; 
        for(int i=0;i<n;++i)cout<<big[i]<<' '; 
        cout<<'\12';*/  
        ans=0;  
        for(int i=0;i<n;++i)ans=(ans+big[i]*low[i])%mod;  
        printf("%d\n",ans);  
    }  
    return 0;  
}  


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值