UVA 725:Division

题目来源:

UVA 725


题目如下:
Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0
through 9 once each, such that the first number divided by the second is equal to an integer N, where2 ≤ N ≤ 79. That is,
abcde / fghij = N
where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.

Input
Each line of the input file consists of a valid integer N. An input of zero is to terminate the program.

Output
Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and,
of course, denominator).
Your output should be in the following general form:
xxxxx / xxxxx = N
xxxxx / xxxxx = N
.
.
In case there are no pairs of numerals satisfying the condition, you must write ‘There are no solutions for N‘. Separate the output for two different values of N by a blank line.

Sample Input
61
62
0

Sample Output
There are no solutions for 61.
79546 / 01283 = 62
94736 / 01528 = 62


题意:
输入正整数n,按照从小到大的顺序输出所有形如abcde/fghiij = n的表达式,其中a-j是0-9的一个排列(可以有前导0),2<=n<=79.

理解:
这道题没有必要枚举0-9的所有排列,只需要枚举fghij乘上n算出abcde再判断是不是都不相同即可。
那么fghij可以从01234开始到54321结束。

判断重复的方式:
由abcde fghij 这两个数定义一个ar[10],下标0-9,每次ar[fghij%10]++,最后判断是否都为1就可以。

代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int main()
{
    int n, s, j, m = 0;
    while(scanf("%d", &n) != EOF && n)
    {
        if(m > 0)
            cout << endl;
        m++;
        int k = 0;
        for(int i = 1234; i < 50000; i++){
        s = n * i;
        if(s >= 12345 && s <= 98765)
        {
            int ii = i;
            int ss = s;
            int ar[10] = {0};
            while(ss){
                ar[ss % 10]++;
                ar[ii % 10]++;
                ss /= 10;
                ii /= 10;
            }
            for(j = 0; j < 10; j++){
                if(ar[j] != 1)
                    break;
            }
            if(j == 10)
            {
            if(i < 10000)
                cout << s << " / 0" << i << " = " << n << endl;
            else
                cout << s << " / " << i << " = " << n << endl;
                    k = 1;
            }
        }
    }
    if(k == 0)
    cout << "There are no solutions for " << n << "." << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值