HDU - 1241 Oil Deposits (DFS)

题目:

HDU - 1241 Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@**@*
5 5
**@
@@@
@*@
@@@*@
@@**@
0 0

Sample Output
0
1
2
2


题目分析

输入n,m两个数代表几行几列,然后输入二维数组里面有*和@,@代表一个油田,只要@的附近8个格子内有@的话,就可以组成一个油田,要求我们去做的是,求一下一共有多少个油田。

这道题我选择用DFS来解决,二维数组的每一个找起,如果出现@的话就进行DFS搜索,其附近的所有的油田,并全都变成*,同时cnt++,连起来的油田就被“挖走了”,然后继续这样的操作,最后输出cnt的值就OK。
这道题也可以用访问数组来标记。


代码如下:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <map>
#include <algorithm>
using namespace std;

int n, m;
char ar[110][110];        //二维数组表示图

void dfs(int x, int y)
{
    ar[x][y] = '*';        //先变成非油田,表示已经考虑过
    for(int dx = -1; dx <= 1; dx++)
    {
        for(int dy = -1; dy <= 1; dy++)
        {
            int nx = x + dx;        //8个方向
            int ny = y + dy;
            if(0 <= nx && nx <= n && 0 <= ny && ny <= m && ar[nx][ny] == '@')        //确保在边界范围内,如果是油田就去访问他
                dfs(nx, ny);        //继续递归搜索
        }
    }
}

int main()
{
    while(cin >> n >> m && n != 0 && m != 0)
    {
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
                cin >> ar[i][j];
        }
    /*
    for(int i = 0; i < n; i++)
    {
        for(int j = 0; j < m; j++)
            cout << ar[i][j];
        cout << endl;
    }
    */
        int cnt = 0;        //计数器
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
            {
                if(ar[i][j] == '@')
                {
                    dfs(i, j);        //搜索
                    cnt++;        //每有一个就+1
                }
            }
        }
        cout << cnt << endl;

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值