OpenJ_Bailian - 1979 -- Red and Black (DFS)

题目:

OpenJ_Bailian - 1979 – Red and Black

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9
….#.
…..#
……
……
……
……
……
##@…#
.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
…@…
###.###
..#.#..
..#.#..
0 0

Sample Output
45
59
6
13


题意:

给出一个n*m的矩形,里面有红色砖块和黑色砖块,一个人站在黑色砖块上用@表示,他可以前后左右4种方向移动,求出他能到达的所有黑色砖块的个数。

分析:

用二维数组表示矩形,用dfs搜索,注意标记,如果红色砖块黑色砖块封住了的话,是不能进去的。


代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

char ar[25][25];        //表示房间地板
int n, m, cnt;

int d[4][2] = {{1, 0}, {0, 1}, {-1, 0}, {0, -1}};    //移动四个方向

void dfs(int i, int j)
{
    ar[i][j] = '!';        //访问过就变成!
    //cout << i << " " << j << endl;
    for(int k = 0; k < 4; k++)
    {
        int x = i + d[k][0];
        int y = j + d[k][1];
        if(x >= 0 && x < n && y >= 0 && y < m && ar[x][y] != '#')       //红色的不能过
        {
            if(ar[x][y] == '.')        //如果是没有访问过的就去访问
            {
                cnt++;
                dfs(x, y);
            }
        }
    }
}

int main()
{
    while(scanf("%d %d", &m, &n) != EOF && m + n)
    {
        int x, y;
        getchar();        //注意吃掉字符!!!!
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
            {
                scanf("%c", &ar[i][j]);
                if(ar[i][j] == '@')
                {
                    x = i;
                    y = j;
                }
            }
            getchar();        //吃掉字符!!!!!
        }
        cnt = 0;
        dfs(x, y);
        cout << cnt + 1 << endl;
    }
    return 0;
}

一定要注意吃掉字符……..本地都过不了都是因为这个…..最后好不容易才搞出来。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值