使用最新版IDEA(2018)+最新版本MySQL(8.0.11)实现Spring+Hibernate时遇到的问题

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/CrazyLmk/article/details/80322996

当配置完属性文件和编写玩代码之后运行main函数时,提示:Unable to create requested service [org.hibernate.engine.jdbc.env.spi.JdbcEnvironment]的错误。通过查找资料发现这个问题是由于MySql的版本不同导致在配置文件application.properties时所使用的方言是不一样的,老版本的Mysql使用的方言好像是
spring.jpa.properties.hibernate.dialect = org.hibernate.dialect.MySQLInnoDBDialect,新版本的Mysql使用的方言是org.hibernate.dialect.MySQL5InnoDBDialect。

没有更多推荐了,返回首页

私密
私密原因:
请选择设置私密原因
  • 广告
  • 抄袭
  • 版权
  • 政治
  • 色情
  • 无意义
  • 其他
其他原因:
120
出错啦
系统繁忙,请稍后再试

关闭