POJ-2386--Lake Counting

原题链接
Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.
    Output

  • Line 1: The number of ponds in Farmer John’s field.
    Sample Input

10 12
W…WW.
.WWW…WWW
…WW…WW.
…WW.
…W…
…W…W…
.W.W…WW.
W.W.W…W.
.W.W…W.
…W…W.
Sample Output

3

用DFS来做,从有‘W’的地方,将当前位置变成‘.’,把当前d循环遍历8个方向,直到没有W为止

#include <iostream>
#include <cstdio>
using namespace std;
const int N = 120;
char g[N][N];//存储
int n,m;
void dfs(int x,int y){
    g[x][y] = '.';//将当前位置置为‘.’

	//循环遍历八个方向
    for(int dx = -1;dx<=1;dx++){dx//
        for(int dy = -1;dy<=1;dy++){
            int nx = x + dx, ny = y + dy;//更新一下
            //判断当前位置是否越界,是否是W可以继续,如果可以就继续调用
            if(nx>=0 && nx<=n && ny>=0 && ny<m && g[nx][ny] == 'W') 						dfs(nx,ny);
        }
    }
    return ;
}

void solve()
{
    int res=0;
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            if(g[i][j]=='W') dfs(i,j),res++;
        }
    }
    printf("%d\n",res);
}
int main()
{
    std::ios::sync_with_stdio(false);
    cin.tie(NULL);
    cin>>n>>m;
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            cin>>g[i][j];
        }
    }
    solve();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值