POJ 1328 Radar Installation

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 56591 Accepted: 12768

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1
 
题目大意:有n艘船及其坐标,在海岸线位置需要安装雷达,已知雷达信号覆盖范围的半径,求最少需要多少个雷达能覆盖完所有船只。若无解,输出-1。
 
解题思路:求出每艘船能被覆盖的雷达坐标区间,给区间按左边界排序,区间重叠部分设置一个雷达,依次往后。
 
解题过程:wa点:注意找枚举雷达坐标的精确值,解题过程发现0.01是精确值。细节注意:最小的右区间边界也算在设置雷达范围内。
 
代码如下:
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=1000005;
const int mixn=1e-10; 
int n;
struct A
{
    double x,y;
}a[maxn];
struct B
{
    double l,r;
}b[maxn];
double cmp(B a,B b)
{
    return a.l<b.l;
}
double findr(int x)
{
	double m=1000000.0;
	for(int i=x;i<n;i++)
		if(m>b[i].r)
			m=b[i].r;
	return m;
}

int main()
{
    int ans,t=0,i,p;
    double d,low,high,cur,minr;
    while(scanf("%d%lf",&n,&d)!=EOF&&(n||d))
    {
        t++,p=0,ans=1;
		minr=1000000.0;
        if(d<=0.0)p=1;
        for(i=0;i<n;i++)
        {
            scanf("%lf%lf",&a[i].x,&a[i].y);
            if(a[i].y>d||a[i].y<0.0)
                p=1;
        }
        if(p)
        {
            printf("Case %d: -1\n",t);
            continue;
        }
        for(i=0;i<n;i++)
        {
            low=a[i].x-d;
            high=a[i].x;
            for(cur=high;cur>=low;cur-=0.01)//这里若采用二分查找临界条件不好判断
            {
                if((a[i].x-cur)*(a[i].x-cur)+(a[i].y*a[i].y)>d*d)
                    break;
            }
            b[i].l=cur;
            low=a[i].x;
            high=a[i].x+d;
            for(cur=low;cur<=high;cur+=0.01)
            {
               if((a[i].x-cur)*(a[i].x-cur)+a[i].y*a[i].y>d*d)
                        break;
            }
            b[i].r=cur;
			if(minr>b[i].r)
				minr=b[i].r;	//找到最小右边界
        }
		sort(b,b+n,cmp);//给区间左边界排序
		for(i=0;i<n;i++)
		{
			if(b[i].l<=minr)continue;
			else
			{
				ans++;
				minr=findr(i);//设置完一个雷达后找新的最小右边界
			}
		}
        printf("Case %d: %d\n",t,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值