POJ 3122

Pie
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11269 Accepted: 3934 Special Judge

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

题目大意:F+1个人来分N个面积可能不同的圆形派,派可以切开,要求每个人分到的派面积相等,但只能是完整的一块不能拼起来。求每个人分到的最大面积的派。


解题思路:经典的二分枚举,以分到派的面积为变量,以分到的人数为判断条件。


解题过程:wa点:PI的精确值,一定要这么大!


代码如下:

#include <cstdio>
#include <algorithm>
using namespace std;
const double PI=3.141592653589793;
int const maxn=10005;
double const m=1e-10;
double a[maxn];//派的面积
int main()
{
    int t,n,f,i,cur;
    double r,low,mid,high,max;
    scanf("%d",&t);
    while(t--)
    {
        max=1,cur=0;
        scanf("%d%d",&n,&f);
        f+=1;
        for(i=0;i<n;i++)
        {
            scanf("%lf",&r);
            a[i]=r*r*PI;
        }
        sort(a,a+n);
        low=0.0;
        high=a[n-1];
        while(high-low>m)
        {
            mid=(high+low)/2;
			cur=0;
            for(i=0;i<n;i++)
            {
                if(a[i]>=mid)
                    cur+=(int)(a[i]/mid);
            }
            if(cur<f)
                high=mid-0.000001;
            else
                low=mid+0.000001;
        }
        printf("%.4f\n",mid);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值