poj 3187 Backward Digit Sums (全排列)

Backward Digit Sums
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4788 Accepted: 2759

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

题目大意:n个数字1-n形成一种排列使累加和的倒三角最底端值为k,输出这种排列,如果有多种情况,输出字典序小的。

解题思路:用STL的next_permutation(a,a+n)函数生成全排列。之后步骤就简单了。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int a[12],b[12];
int main()
{
    int i,n,k;
    scanf("%d%d",&n,&k);
    for(i=0;i<n;i++)  //排列为1-n递增的情况
	{
        a[i]=i+1;
		b[i]=a[i];
	}
    int m=n;
	while(m>1)
	{
		for(i=0;i<m-1;i++)
			b[i]+=b[i+1];
		m--;
	}
	if(b[0]==k)
	{
		for(i=0;i<n;i++)
		{
			if(i)
				printf(" ");
			printf("%d", a[i]);
		}
		printf("\n");
		return 0;
	}
    while(next_permutation(a,a+n))
	{
		for(i=0;i<n;i++)  //三角形累加过程
			b[i]=a[i];
        m=n;
		while(m>1)
		{
			for(i=0;i<m-1;i++)
				b[i]+=b[i+1];
			m--;
		}
		if(b[0]==k)break;
    }
    for(i=0;i<n;i++)
    {
        if(i)
            printf(" ");
        printf("%d", a[i]);
    }
	printf("\n");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值