【PAT 甲级】1007 Maximum Subsequence Sum

1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题目大意:

 求最大连续子序列和,输出最大和、子序列的首尾数字。若遇到相同和的最大连续子序列,输出靠前的那个。若原数列均为负数,则默认最大和为0,最大子序列为原序列。

我的代码:

#include <iostream>
using namespace std;
int main(){
	int K;  //数组个数 

	cin >> K;
	int *a = new int [K];  //动态创建数组 
	int t=-1;   
	for (int i=0; i<K; i++) {
		cin>>a[i];  //输入数组 
		if ((t==-1)&&(a[i]>=0)) {
			t=i;  //记录第一次出现正数的下标 
		}
	}  
	
	int sum=0, MaxSum=0, left=t, right=t, mayLeft=t;  
	if (t==-1) {
		//如果都是负数,则直接默认最大和为0,输出首尾 
		left = 0;
		right = K-1;
	} else {
		for (int i=t; i<K; i++) {
			sum += a[i];
			if (sum>MaxSum) {
				//更新最大子列
				MaxSum = sum;
				left = mayLeft;
				right = i; 
			} else if (sum<0) {
				//若和为负数,则将前面所有舍弃, 可能的最大子列左下标更新为i+1 
				mayLeft = i+1;
				sum = 0;
			}
		}	
	} 

	//输出 
	cout<<MaxSum<<' '<<a[left]<<' '<<a[right];
	
	delete[] a; 
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值