C++哈希算法和map排序

7-1 词频统计(30 分)

请编写程序,对一段英文文本,统计其中所有不同单词的个数,以及词频最大的前10%的单词。

所谓“单词”,是指由不超过80个单词字符组成的连续字符串,但长度超过15的单词将只截取保留前15个单词字符。而合法的“单词字符”为大小写字母、数字和下划线,其它字符均认为是单词分隔符。

输入格式:

输入给出一段非空文本,最后以符号#结尾。输入保证存在至少10个不同的单词。

输出格式:

在第一行中输出文本中所有不同单词的个数。注意“单词”不区分英文大小写,例如“PAT”和“pat”被认为是同一个单词。

随后按照词频递减的顺序,按照词频:单词的格式输出词频最大的前10%的单词。若有并列,则按递增字典序输出。

输入样例:

This is a test.

The word "this" is the word with the highest frequency.

Longlonglonglongword should be cut off, so is considered as the same as longlonglonglonee.  But this_8 is different than this, and this, and this...#
this line should be ignored.

输出样例:(注意:虽然单词the也出现了4次,但因为我们只要输出前10%(即23个单词中的前2个)单词,而按照字母序,the排第3位,所以不输出。)

23
5:this
4:is

感谢武汉理工大学的郭小兵老师修正测试数据!

这篇就是哈希算法的C++实现,以前用C实现代码很长,消耗时间很多,C++则简单明了很多。

用map<?,?>来代替以前的struct;

用起来很简单,但是最后麻烦是map居然不能用sort排序;

然后学习了一种map的排序方法;

        首先,看pair<?,?> 和map<?,?>;

多个pair<?,?>可以线性储存,然后就可以用sort排序了;

     vector<pair<string,int> > v;
     for(it=mp.begin();it!=mp.end();it++)
    {
        v.push_back(make_pair(it->first,it->second));

    }

     sort(v.begin(),v.end(),compare);

然后比较函数就是:

bool compare(pair<string,int> p1,pair<string,int> p2)
{
    if(p1.second>p2.second) return 1;
    else if(p1.second==p2.second)
    {
        if(p1.first<p2.first) return 1;
        else return 0;
    }

    else return 0;

}

然后map的排序就成功了;

附上代码:

#include <stdio.h>
#include <string>
#include <iostream>
#include <map>
#include <string.h>
#include <algorithm>
#include <vector>
using namespace std;
bool compare(pair<string,int> p1,pair<string,int> p2)
{
    if(p1.second>p2.second) return 1;
    else if(p1.second==p2.second)
    {
        if(p1.first<p2.first) return 1;
        else return 0;
    }
    else return 0;
}
int main()
{
    map<string,int> mp;
    char a[100]={0};
    char c;
    while(1)
    {
        if(scanf("%80[a-zA-Z_0-9]",a))
        {
            if(strlen(a)>15) a[15]=0;
            for(int i=0;i<strlen(a);i++)
                a[i]=tolower(a[i]);
            string s= a;
            mp[s]++;
        }
        c =getchar();
        if(c=='#') break;
    }
    while(cin>>a);
    map<string,int>::iterator it;
    vector<pair<string,int> > v;
    for(it=mp.begin();it!=mp.end();it++)
    {
        v.push_back(make_pair(it->first,it->second));
    }
    sort(v.begin(),v.end(),compare);
    cout<<v.size()<<endl;
    for(int i=0;i<v.size()/10;i++)
        cout<<v[i].second<<':'<<v[i].first<<endl;
return 0;
}

  • 1
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值