1021 Deepest Root (25)(25 point(s))(cj)

1021 Deepest Root (25)(25 point(s))Questions

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

吐血 ~ ~  一直以为 bool graph[10001][10001] 肯定不会超内存,结果最后还是超了。

改成 vector<int> graph[10001] 就不超内存。

事实证明 数组还是不要开太大。

方法 是并查集 求有无环和连通集, dps求最深的根dian 

#include <iostream>
#include <vector>
#include <stdio.h>
using namespace std;
int arr[10005];
vector<int> graph[10005];
int findf(int x);
bool unionf(int x,int y);
bool vis[10005];
int dps(int p,int n,int h);
int main(){
    int n;
    cin>>n;
    int x,y;
    bool f=1;
    for(int i=0;i<n-1;++i){
        cin>>x>>y;
        if(unionf(x,y)==0){
            f=0;
        }
        graph[x].push_back(y);
        graph[y].push_back(x);
    }
    int num=0;
    for(int i=1;i<=n;++i){
        if(arr[i]==0) num++;
    }
    if(num!=1||f==0){
        printf("Error: %d components",num);
    }
    else{
        for(int i=1;i<=n;++i){
            arr[i]=0;
        }
        int Max=0;
        for(int i=1;i<=n;++i){
            if( (arr[i]=dps(i,n,1)) >Max){
                Max=arr[i];
            };
        }
        for(int i=1;i<=n;++i){
            if(arr[i]==Max) cout<<i<<endl;
        }
    }
    return 0;
}
int dps(int p,int n,int h){
    vis[p]=1;
    int Max=h;
    for(int i=0;i<graph[p].size();++i){
        if(vis[ graph[p][i] ]==0){
            int x = dps(graph[p][i],n,h+1);
            if(x>Max) Max = x;
        }
    }
    vis[p]=0;
    return Max;
}
int findf(int x){
    return arr[x]==0? x: arr[x]=findf(arr[x]);
}
bool unionf(int x,int y){
    int fx = findf(x);
    int fy = findf(y);
    if(fx==fy) return 0;
    arr[x]=fy;
    arr[fx]=fy;
    return 1;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值