1040 Longest Symmetric String (25)(25 point(s))

1040 Longest Symmetric String (25)(25 point(s))

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

思路就是 一个个判断。 

 code

#include <iostream>
#include <string>
using namespace std;
int issymmetric(int pos,int size);
string str;
int main() {
	string s;
	getline(cin, s);
	for (int i = 0; i < s.size(); ++i) {
		str += ' ';
		str += s[i];
	}
	str += ' ';
	int max = 0;
	for (int i = 0; i < str.size(); ++i) {
		int x = issymmetric(i,str.size());
		if (x > max) max = x;
	}
	cout << max << endl;
	system("pause");
	return 0;
}
int issymmetric(int pos,int size) {
	int i = 1;
	while (pos - i >= 0 && pos + i < size&&str[pos - i] == str[pos + i]) i++;
	/*if (pos - i >= 0 && pos + i < size) {
		for (int j = pos - i+1; j <= pos + i-1; j++) {
			cout << str[j];
		}
		cout << endl;
	}*/
	return i - 1;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值