1045 Favorite Color Stripe (30)(30 point(s) 可重复LCS

1045 Favorite Color Stripe (30)(30 point(s))

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (<=200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (<=10000) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

 思路是最长公共子序列的思想,只是 可以重复等于相同的一个元素了。所以状态转移方程需要变换。

如果不能重复等于同一个元素 

if ( a[i] == b[j] ) maxn[i][j] = maxn[i-1][j-1] +1;
else maxn[i][j] = max( maxn[i][j-1] , maxn[i-1][j] )

如果可以重复等于

if (a[i]==b[j] ) maxn[i][j] = max( maxn[i-1][j] , maxn[i][j-1] ) +1;
else maxn[i][j] = max ( maxn[i-1][j] ,maxn[i][j-1] )

其中 maxn[i][j] = maxn[i-1][j-1] + 1  就是将重复等于的去掉了。

而 maxn[i][j] = max( maxn[i-1][j] , maxn[i][j-1] ) +1; 是在可以重复的基础上 相同加1。

code

代码是二维数组 改成 一维数组的 做法。

#include <iostream>
#include <vector>
using namespace std;
int arr1[210];
int maxn[210];
int main() {
	int n, m, x;
	cin >> n >> m;
	for (int i = 1; i <= m; ++i) {
		cin >> arr1[i];
	}
	int l;
	cin >> l;
	for (int i = 0; i < l; ++i) {
		cin >> x;
		for (int j = 1; j <=m ; ++j) {
			int Max = maxn[j];
			if (maxn[j - 1] > Max) Max = maxn[j-1];
			if (arr1[j] == x) maxn[j] = Max+1;
			else maxn[j] = Max;
		}
	}
	cout << maxn[m];
	system("pause");
	return 0;
}

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值