1049 Counting Ones (30)(30 point(s)(cj)

1049 Counting Ones (30)(30 point(s))

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (<=2^30^).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:

12

Sample Output:

5

 思路:对于整数,我们计算他前一位 前俩位 前三位 等等的 含有1的个数,比如

  •  个位只有 1
  • 十位和个位共有 (9*1 +10^{1})(1-9 数的个位是1的数量 和十位是1的数量)+ 个位数量 1 = 20
  • 百位 (9*20 + 10^{2} )+ 20= 300;

此位不是1时 到此位时所有的有1的数数量 和此位是1是 数量和,重复数使得计算出数字中1的个数。

如果有大小限制的话。

此位为0时 没有增加数量,因为 012 就是 12 本身。

此位为1时,totalsum += (n%num+1) (就像123  从 100到 123);      totalsum += bitsum (就像 123 上十位个位 0-99中1的个数);

此位为>1时,totalsum += bitallsum (就是 100-199);  totalsum += (part)*bitsum (0-99含1个数×part);

#include <iostream>
#include <string>
using namespace std;
long long deal(long long n);
int main(){
	long long n;
	while (cin >> n)
		cout << deal(n) << endl;
	system("pause");
	return 0;
}
long long deal(long long n) {
	long long totalsum = 0;
	long long bitallsum = 1;
	long long bitsum = 0;
	long long num = 1;
	while (n/num) {
		long long part = (n / num) % 10 ;
		if (part == 1) {
			totalsum += (n%num+1);
			totalsum += bitsum;
		}
		else if(part > 1) {
			totalsum += bitallsum;
			totalsum += (part)*bitsum;
		}
		bitsum += (9 * bitsum + bitallsum);
		bitallsum *= 10;
		num *= 10;
	}
	return totalsum;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
题目简述: 给定一个整数n,你需要求出1到n这n个整数的二进制(binary)表示中数字1出现的次数。例如,对于n=3,1到3这3个整数的二进制表示分别是:1, 10, 11,其中1出现的次数为2次。因此,输出2即可。 题目思路: 这道题可以用暴力求解法:枚举1到n的每个整数,然后统计对应的二进制表示中1的个数即可。但此种做法不适用于大数据。因此,我们需要寻找更为高效的算法。其中一种常见方法是用每一位的数字来计算。 例如,对于一个二进制数11010,我们可以从低到高,第一位统计在0~1范围内出现的次数,第二位统计在0~3范围内出现的次数,第三位在0~7范围内,第四位在0~15范围内,最后统计总体中的1的个数。因为,我们可以发现,对于n的第i位上的数字,它出现1的次数由(n / (i*10) * i)个1,除去i-1位之后,如果大于2,则还要加上i个1。再来看一个具体的例子,对于11010,第一位上有10种情况,0出现5次,1也出现5次,对于第二位,共有110, 101, 100, 011, 010, 001, 000七种情况,其中从00到01这两种情况中,每个数字都出现了两次1,因此一共出现了2*2=4次1。同样地,对于 101 和 011 这两种情况,也是如此。 因此,最终代码如下(基于C++): #include <iostream> using namespace std; #define int long long//避免溢出 signed main(){ int n, ans; cin >> n; for(int l = 1, r; l <= n; l = r + 1){ int k = n / l; r = n / k; ans += (r - l + 1) * (k / 10); int t = (k % 10) * l; if(t >= l) ans += t - l + 1; } cout << ans << endl; return 0; } 注意:本题的数据范围比较大,因此需要使用int long long类型避免溢出。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值