1049 Counting Ones (30 分)
The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.
Input Specification:
Each input file contains one test case which gives the positive N (≤230).
Output Specification:
For each test case, print the number of 1's in one line.
Sample Input:
12
Sample Output:
5
比如21910
//21910
//(1 * 10000) + (2 * 1000 + 910 + 1 ) + (22 * 100) + ( 219 * 10 + 1) +(2191)
#include<bits/stdc++.h>
using namespace std;
int main()
{
int sum = 0, n , a = 1;
scanf("%d", &n);
int kk;
while(n / a != 0)
{
int left = n / (a * 10);
int now = n / a % 10;
int right = n % a;
kk = sum;
if(now == 0)
sum += left * a;
else if(now == 1)
sum += left * a + right + 1;
else
sum +=(left + 1) * a;
a = a * 10;
printf("%d \n", sum - kk);
}
cout<<sum <<endl;
return 0;
}