1082 Read Number in Chinese(25 分)(cj)

1082 Read Number in Chinese(25 分)

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output Fu first if it is negative. For example, -123456789 is read as Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu. Note: zero (ling) must be handled correctly according to the Chinese tradition. For example, 100800 is yi Shi Wan ling ba Bai.

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:

-123456789

Sample Output 1:

Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu

Sample Input 2:

100800

Sample Output 2:

yi Shi Wan ling ba Bai

俩个坑点可以用来参考,第一个 输入是 0 的时候 和 前缀是 0 的时候, 第二个是 10000000 是 yi Yi 而不是 yi Yi Wan

code

#pragma warning(disable:4996)
#include <iostream>
#include <string>
using namespace std;
string num[10] = { "ling","yi","er","san","si","wu","liu","qi","ba","jiu" };
string a[4] = { ""," Shi"," Bai"," Qian" };
int main() {
	string s;
	cin >> s;
	if (s[0] == '-') {
		cout << "Fu ";
		s.erase(s.begin());
	}
	while (s[0] == '0') s.erase(s.begin());
	if (s == "") {
		cout << num[0];
		system("pause");
		return 0;
	}
	bool f = 1;
	bool ff = 0;
	bool f3 = 0;
	for (int i = 0; i < s.size(); ++i) {
		if(s[i] != '0'){
			if (f) f = 0;
			else cout << ' ';
			if (ff) cout << num[0] << ' ';
			cout << num[s[i] - '0'];
			cout << a[(s.size() - 1 - i) % 4];
			ff = 0;
			f3 = 1;
		}
		else {
			ff = 1;
		}
		if ((s.size() - 1 - i) % 4 == 0) {
			if ((s.size() - 1 - i) / 4 == 1) {
				if(f3) cout << " Wan";
			}
			else if ((s.size() - 1 - i) / 4 == 2) {
				cout << " Yi";
				f3 = 0;
			}
		}
	}
	system("pause");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值