[C/C++] 1082 Read Number in Chinese(25 分)

1082 Read Number in Chinese(25 分)

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output Fu first if it is negative. For example, -123456789 is read as Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu. Note: zero (ling) must be handled correctly according to the Chinese tradition. For example, 100800 is yi Shi Wan ling ba Bai.

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:

-123456789

Sample Output 1:

Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu

Sample Input 2:

100800

Sample Output 2:

yi Shi Wan ling ba Bai

目前测试点0和测试点4格式错误,标记下,回头改

#include<stdio.h> 
#include<string.h>

void reverse(char a[]){
    int len = strlen(a)-1; 
    for(int i = 0;i<len/2;i++) {
        char t = a[i];
        a[i] = a[len-1-i];
        a[len-1-i] = t;
    }
}
int main(){ 
    char danwei[10][5] ={"","Shi","Bai","Qian","Wan","Shi","Bai","Qian","Yi"};
    char duyin[10][5] = {"ling","yi","er","san","si","wu","liu","qi","ba","jiu"};
    char s[15];
    fgets(s,15,stdin);
    reverse(s);

    int len = strlen(s);
    for(int i = len -2;i>=0;i--) {
        if(s[i] == '-') printf("Fu ");
        else {
            if(s[i] != '0'&&s[i+1]=='0') {//不为0而且高位为0 
                printf(" ling %s %s",duyin[s[i]-'0'],danwei[i]);

            }else if(s[i]!='0'){//不为0而且高位不为0 
                if(s[i+1] == '\n') printf("%s %s",duyin[s[i]-'0'],danwei[i]);
                else printf(" %s %s",duyin[s[i]-'0'],danwei[i]);

            }else {//为0而且高位不为0 
                if (i == 0 && s[i+1] == '\n') printf("ling");//单独一个0 
                else if(i == 4||i ==8) printf(" %s",danwei[i]);//Wan或Yi 
                else continue;
            }   
        }
    } 


    return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值