1086 Tree Traversals Again(25 分)

1086 Tree Traversals Again(25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

入堆的顺序正好是先序遍历,出堆的顺序正好是中序遍历,所以这题就变成了 已知前序遍历和中序遍历求 后序遍历。 

code

#pragma warning(disable:4996)
#include <iostream>
#include <string>
#include <vector>
#include <stack>
using namespace std;
int tree[100000];
vector<int> preorder;
vector<int> inorder;
stack<int> st;
void buidtree(int L, int R, int l, int r, int pos);
void postorder(int pos);
bool f = 1;
int main() {
	int n;
	cin >> n;
	string op;
	int x;
	for (int i = 0; i < 2*n; ++i) {
		cin >> op;
		if (op == "Push") {
			cin >> x;
			st.push(x);
			preorder.push_back(x);
		}
		if (op == "Pop") {
			inorder.push_back(st.top());
			st.pop();
		}
	}
	buidtree(0, n - 1, 0, n - 1, 1);
	postorder(1);
	system("pause");
	return 0;
}
void buidtree(int L, int R, int l, int r, int pos) {
	if (L > R || l > r) return;
	int x = preorder[L];
	tree[pos] = x;
	int i;
	for (i = l; i <= r; ++i) {
		if (inorder[i] == x) break;
	}
	int lt_size = i - l;
	int rt_size = r - i;
	buidtree(L + 1, L + lt_size, l, i - 1, pos * 2);
	buidtree(L + lt_size + 1, R, i + 1, r, pos * 2 + 1);
}
void postorder(int pos) {
	if (tree[pos] == 0) return;
	postorder(pos * 2);
	postorder(pos * 2 + 1);
	if (f) f = 0;
	else cout << ' ';
	cout << tree[pos] ;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值