1104 Sum of Number Segments(20 分)
Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).
Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.
Output Specification:
For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.
Sample Input:
4
0.1 0.2 0.3 0.4
Sample Output:
5.00
Google 的题就是不一样 真的很细节 挖了好多次。 int*int*double 转换是 int*int 变为 int ,然后 int *double
但是 当 i 去100000时 int *int 可能会溢出,然后就答案错误,解决方法要么把int换为long long 要么把 double 提前
使得 double * int 变为 double
code
#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <stdio.h>
using namespace std;
int main() {
int n;
cin >> n;
double x, sum = 0.0;
for (int i = 0; i < n; ++i) {
cin >> x;
sum = sum + (i+1)*(n-i)*x;
}
printf("%.2f", sum);
system("pause");
return 0;
}