1119 Pre- and Post-order Traversals(30 分)(cj)

1119 Pre- and Post-order Traversals(30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

就是通过 dfs 来找中序遍历的结果。

重点就是 如果 一个点只有一个子节点 先后序遍历都无法确定这个子节点是左节点还是右节点。

如果一个点有左右子节点,他的先后序遍历是可以确定左右的。

所以以此为突破口解题,注意就是不要少了任何一个点。还有输出末尾要加回车,不然会格式错误。。

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
using namespace std;
int postarr[35], prearr[35];
bool f = 1;
vector<int> varr;
void dfs(int q, int e, int l, int r) {
	if (q > e) {
		f = 0;
		return;
	}
	if (q == e) {
		varr.push_back(prearr[q]);
		return;
	}
	int x = prearr[q + 1];
	int y = postarr[r - 1];
	int xx, yy;
	for (int i = q; i <= e; ++i) {
		if (prearr[i] == y) {
			yy = i;
			break;
		}
	}
	for (int i = l; i <= r; ++i) {
		if (postarr[i] == x) {
			xx = i;
			break;
		}
	}
	dfs(q + 1, yy - 1, l, xx);
	varr.push_back(prearr[q]);
	dfs(yy, e, xx + 1, r - 1);
}
int main() {
	int n;
	cin >> n;
	for (int i = 0; i < n; ++i) {
		cin >> prearr[i];
	}
	for (int i = 0; i < n; ++i) {
		cin >> postarr[i];
	}
	dfs(0, n - 1, 0, n - 1);
	if (f) cout << "Yes" << endl;
	else cout << "No" << endl;
	for (int i = 0; i < varr.size(); ++i) {
		if (i != 0) cout << ' ';
		cout << varr[i];
	}
	cout << endl;
	system("pause");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值