1119 Pre- and Post-order Traversals (30 分)

1119 Pre- and Post-order Traversals (30分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

这题真不好做。考了一个前序后序遍历建树并判断树的唯一性。是否唯一还好说,但是建树是真的不太容易,不看答案我真写不出来。看到这种方法了,就背过,好好学会。注意其中的几个我注释的地方。

#include <bits/stdc++.h>
#define N 105
using namespace std;
typedef struct bt{
    int data;
    bt *lc,*rc;
}bt;
int pre[N],post[N],n,flag=1,cnt;
bt* prePostBuildTree(int prel,int prer,int postl,int postr)  {
    if (prel>prer)  return nullptr;     //第二次看答案才加上
    bt* nw=new bt;
    nw->data=pre[prel];
    nw->lc=nullptr;nw->rc=nullptr;
    if (prel==prer) return nw;          //第二次看答案才加上
    int i=prel+1;
    while (i<=prer&&pre[i]!=post[postr-1])  i++;	//i的改变值即为左子树的节点数
    if (i>prel+1)   {		//注意下标的取值,要明白下面八个参数为什么这么取
        nw->lc=prePostBuildTree(prel+1,i-1,postl,postl+i-prel-2);
        nw->rc=prePostBuildTree(i,prer,postl+i-prel-1,postr-1);
    }
    else{		//如果i不移动,说明左子树为空
        flag=0;		//说明不唯一
        nw->rc=prePostBuildTree(i,prer,postl+i-prel-1,postr-1);
    }
    return nw;
}
void inOrderTraversal(bt* root) {
    if (root==nullptr)  return;
    inOrderTraversal(root->lc);
    printf("%d%c",root->data,(cnt++)==n-1?'\n':' ');
    inOrderTraversal(root->rc);
}
int main()  {
    cin>>n;
    for (int i=0;i<n;i++)   scanf("%d",&pre[i]);
    for (int i=0;i<n;i++)   scanf("%d",&post[i]);
    bt* root=prePostBuildTree(0,n-1,0,n-1);
    printf("%s\n",flag?"Yes":"No");
    inOrderTraversal(root);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值