1135 Is It A Red-Black Tree (30 分)(cj)

1135 Is It A Red-Black Tree (30 分)

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpgrbf2.jpgrbf3.jpg
Figure 1Figure 2Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

看到题 才知道有红黑树这东西 =. =  只能查了一些很基础的属性 然后来做题了,幸亏 题不算难。。。

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <stdio.h>
#include <algorithm>
#define inf 0x7fffffff
#define fabs(x) (x<0?-x:x)
using namespace std;
class tree {
public:
	int val;
	tree *left = NULL, *right = NULL;
};
vector<int> preorder;
void build(int l, int r, tree*& p);
void pretravel(tree* p);
bool ju(tree* p);
int travel(tree* p);
int getdarknum(tree* p);
int main() {
	int k;
	cin >> k;
	while (k--) {
		int n, x;
		cin >> n;
		preorder.clear();
		for (int i = 0; i < n; ++i) {
			cin >> x;
			preorder.push_back(x);
		}
		tree* p =NULL;
		build(0, n - 1, p);
		if (ju(p) && travel(p)&&p->val>0) {
			cout << "Yes" << endl;
		}
		else cout << "No" << endl;
	}
	system("pause");
	return 0;
}
bool ju(tree* p) {
	if (p == NULL) return 1;
	int a = getdarknum(p->left);
	int b = getdarknum(p->right);
	if (a != b) return 0;
	return ju(p->left)&&ju(p->right);
}
int travel(tree* p) {
	if (p == NULL) return 1;
	if (p->val < 0) {
		if ((p->left == NULL || p->left->val > 0) && (p->right == NULL || p->right->val > 0));
		else return 0;
	}
	return travel(p->left) && travel(p->right);
}
int getdarknum(tree* p) {
	if (p == NULL) return 0;
	int g = 0;
	if (p->val > 0) {
		g = 1;
	}
	return max(getdarknum(p->right),getdarknum(p->left)) + g ;
}
void pretravel(tree* p) {
	if (p == NULL) return;
	cout << p->val<<' ';
	pretravel(p->left);
	pretravel(p->right);
}
void build(int l, int r, tree*& p) {
	if (l > r) return;
	p = new tree;
	p->val = preorder[l];
	if (l == r) return;
	int pos;
	for (pos = l+1; pos <= r; ++pos) {
		if (fabs(preorder[pos]) >= fabs(preorder[l])) break;
	}
	build(l + 1, pos - 1, p->left);
	build(pos, r, p->right);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值