PAT甲级——1135 Is It A Red-Black Tree (30 分)

1135 Is It A Red-Black Tree (30 分)

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpgrbf2.jpgrbf3.jpg
Figure 1Figure 2Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

题目大意:给出K个树,判断是否为红黑树;

红黑树是每个节点都带有颜色属性的二叉查找树,颜色为红色黑色。在二叉查找树强制一般要求以外,对于任何有效的红黑树又有如下的额外要求:(定义来源:红黑树的维基百科

  1. 节点是红色或黑色。
  2. 根是黑色。
  3. 所有叶子都是黑色(叶子是NIL节点)。
  4. 每个红色节点必须有两个黑色的子节点。(从每个叶子到根的所有路径上不能有两个连续的红色节点。)
  5. 从任一节点到其每个叶子的所有简单路径都包含相同数目的黑色节点

思路:第4点只需要一次DFS判断就可以解决。第5点的要求,对于每个节点,先获取它的左右子树黑色节点的高度,再进行判断;这里全是递归,真的很绕脑~~

#include<iostream>
#include<queue>
#include<cmath>
using namespace std;
typedef struct node* BT;
struct node{
	int data=0;
	BT LChild=NULL,RChild=NULL;
};

BT BuildBST(BT t,int num);//建立二叉搜索树
bool NodeColor(BT t);//判断节点的颜色是否符合要求 
int getNum(BT t);//获取当前节点的左右子树的高度(仅为黑色节点的高度)
bool isRBT(BT t);//判断是否为红黑树
bool BlackNode(BT t);//判断黑色节点的数量是否符合要求 

int main()
{
	int K;
	scanf("%d",&K);
	for(int i=0;i<K;i++){
		int N;
	    BT tree=NULL;
	    scanf("%d",&N);
	    for(int i=0;i<N;i++){
		     int tmp;
		     scanf("%d",&tmp);
		     tree=BuildBST(tree,tmp);
	    }
    	if(isRBT(tree))
	        printf("Yes\n");
	    else
	        printf("No\n");
	} 
	return 0;
}

bool BlackNode(BT t)
{
	if(t==NULL) return true;
	int Lnum=getNum(t->LChild);
	int Rnum=getNum(t->RChild);
	if(Lnum!=Rnum) return false;
	return BlackNode(t->LChild)&&BlackNode(t->RChild);
}

bool isRBT(BT t)
{
	return BlackNode(t)&&NodeColor(t)&&t->data>0;
}

int getNum(BT t)
{
	if(t==NULL)
		return 0;
	int Lnum=getNum(t->LChild);
	int Rnum=getNum(t->RChild);
	return (t->data>0)?max(Lnum,Rnum)+1:max(Lnum,Rnum); 
}

bool NodeColor(BT t)
{
	if(t==NULL) return true;
	if(t->data<0){
		if((t->LChild!=NULL&&t->LChild->data<0)||(t->RChild!=NULL&&t->RChild->data<0)){
			return false;
		}
	}
	return NodeColor(t->LChild)&&NodeColor(t->RChild);
}

BT BuildBST(BT t,int num)
{
	if(t==NULL){
		t=new node();
		t->data=num;
	}
	else{
		if(abs(num)<abs(t->data))
		    t->LChild=BuildBST(t->LChild,num);
	    else
	        t->RChild=BuildBST(t->RChild,num);
	}
	return t;
}

 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值