Treats for the Cows 区间dp

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time. 

The treats are interesting for many reasons:

  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.

Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally? 

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
附上错误代码,希望有高手能帮我找出错误
//dp[i][j]表示i和j之间的元素还没被选择
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
int p[2010];
int dp[2010][2010];
int n;

int main()
{
    while(cin>>n)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d",p+i);
        }
        memset(dp,0,sizeof(dp));
        dp[0][n-2]=p[n-1];
        dp[1][n-1]=p[0];int i,j;
        int ans=0;
        for(i=1;i<n;i++)
        {
            for(j=n-2;j>-1&&j>=i;j--){
                dp[i][j]=max(dp[i-1][j]+p[i-1]*(n-j+i),dp[i][j+1]+p[j+1]*(n-j+i));
                if(i==j){
                    ans=max(dp[i][j],ans);
                }
            }
        }
        cout<<ans-1<<endl;
    }
}
1
3
1
5
2

Sample Output

43
将n个数据放在队列中,每次可以从队首或队尾选择一个元素,直到将所有的元素
选择完,求每一个元素乘以该元素的被选择的次序的值的和的最大值

#include<stdio.h>
#include<algorithm>
#include<cstring>
using namespace std;

int dp[2005][2005];
int v[2005];


int main()
{
	int i,j,n;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=1;i<=n;i++)
			scanf("%d",&v[i]);
		memset(dp,0,sizeof(dp));
		for(i=0;i<=n;i++)
			for(j=0;i+j<=n;j++)
			{
				if(i==0&&j==0)
					dp[i][j]=0;
				else if(i==0&&j!=0)
					dp[i][j]=max(dp[i][j],dp[i][j-1]+v[n-j+1]*(i+j));
				else if(i!=0&&j==0)
					dp[i][j]=max(dp[i][j],dp[i-1][j]+v[i]*(i+j));
				else
					dp[i][j]=max(dp[i-1][j]+v[i]*(i+j),dp[i][j-1]+v[n-j+1]*(i+j));
			}
		int ans=0;
		for(i=0;i<=n;i++)
			if(dp[i][n-i]>ans)
				ans=dp[i][n-i];
		printf("%d\n",ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值