Navigition Problem

Navigation is a field of study that focuses on the process of monitoring and controlling the movement of a craft or vehicle from one place to another. The field of navigation includes four general categories: land navigation, marine navigation, aeronautic navigation, and space navigation. (From Wikipedia)
Recently, slowalker encountered a problem in the project development of Navigition APP. In order to provide users with accurate navigation service , the Navigation APP should re-initiate geographic location after the user walked DIST meters. Well, here comes the problem. Given the Road Information which could be abstracted as N segments in two-dimensional space and the distance DIST, your task is to calculate all the postion where the Navigition APP should re-initiate geographic location.

 

Input

The input file contains multiple test cases.
For each test case,the first line contains an interger N and a real number DIST. The following N+1 lines describe the road information.
You should proceed to the end of file.

Hint:
1 <= N <= 1000
0 < DIST < 10,000

 

Output

For each the case, your program will output all the positions where the Navigition APP should re-initiate geographic location. Output “No Such Points.” if there is no such postion.

 

Sample Input

2 0.50
0.00 0.00
1.00 0.00
1.00 1.00

Sample Output

0.50,0.00
1.00,0.00
1.00,0.50
1.00,1.00

n+1个点构成n段路,从第一个点出发,没经过距离d,输出该位置的坐标

https://blog.csdn.net/nameofcsdn/article/details/80289060

 

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <math.h>
#include <algorithm>
using namespace std;
const int N = 1005;
struct Point
{
    double x,y;
} p[N];
struct Line
{
    Point a,b;
} line[N];
double len[N];
double dis(Point a,Point b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double sum[N];
int main()
{
    int n;
    double d;
    while(scanf("%d%lf",&n,&d)!=EOF)
    {
        double SUM = 0;
        sum[0] = 0;
        for(int i=1; i<=n+1; i++)
        {
            scanf("%lf%lf",&p[i].x,&p[i].y);
            if(i>1)
            {
                len[i-1] = dis(p[i],p[i-1]);
                SUM+=len[i-1];
                sum[i-1] = sum[i-2]+len[i-1];
            }
        }
        if(SUM<d)
        {
            printf("No Such Points.\n");
            continue;
        }
        double now = 0,k,x,y;///now 表示目前走过的长度
        for(int i=1; i<=n;)
        {
            if(now+d<=sum[i])///sum[i]表示前i段路线的和
            {
                double L = now+d - sum[i-1];
                double x1 = p[i].x,y1 = p[i].y;
                double x2 = p[i+1].x,y2 = p[i+1].y;
                if(x1!=x2)
                {
                    k = (y1-y2)/(x1-x2);
                    if(x2<x1)
                    {
                        x = x1-sqrt((L*L)/(k*k+1));
                        y = k*(x-x1)+y1;
                    }
                    else
                    {
                        x = x1+sqrt((L*L)/(k*k+1));
                        y = k*(x-x1)+y1;
                    }
                }
                else
                {
                    x = x1;
                    if(y2<y1) y = y1-L;
                    else  y = y1+L;
                }
                printf("%.2lf,%.2lf\n",x,y);
                now = now+d;
            }
            else
            {
                i++;
            }
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值