树状数组 POJ2352 思路

9 篇文章 0 订阅
3 篇文章 0 订阅

Stars

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 54300 Accepted: 23361

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

 

题目大意:

一个星星的左下角的矩形里(包括边但不包括此星星)有l颗星,那么它的等级就为l。

 

分析:

因为星星的坐标是按照y升序给出,y相等情况下按x升序给出,意味着x[i]<=x[j]时,一定有有y[i]<=y[j]成立。并且,读入到该点之后,不会再有星星出现在它左下角的矩形里。

则只需在每读入一个星星坐标时,统计x<=当前星坐标的星星个数即可得出当前星星等级。

所以无需处理y,只需处理x,维护关于x的树状数组。b[i]是i-1坐标前(包括i-1)树状数组所定义的长度包含的星星坐标的个数。

每次读入先统计x小于等于当前x的星星总数,得出该星等级,统计结果++;然后进行修改操作,将本结点及其父亲们都++。

//树状数组感受一下

 

感受代码:

#include <cstdio>
#include <cstring>
#define lowbit(x) x&(-x)

const int maxn=15000;
const int maxx=32002;

int n;
int c[maxx],ans[maxn];

//求和操作
int sum(int x)
{
	int sum=0;
	for(;x;x-=lowbit(x)){
		sum+=c[x];
	}
	return sum;
}

//修改操作
void modify(int x)
{
	for(;x<=maxx;x+=lowbit(x)){
		++c[x];
	}
}

int main()
{
	int a,b;

	while(~scanf("%d",&n)){
		memset(ans,0,sizeof(ans));
		memset(c,0,sizeof(c));
		for(int i=1;i<=n;++i){
			scanf("%d%d",&a,&b);
			++a;	//x可能=0,后移一位
			++ans[sum(a)];	//先求和然后那个答案数便+1
			modify(a);	//注:操作顺序
		}
		for(int i=0;i<n;++i){
			printf("%d\n",ans[i]);
		}
	}

	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值