HDU 1008 Elevator

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case. 
 

Sample Input
  
  
1 2 3 2 3 1 0
 

Sample Output
  
  
17 41
 

Author
ZHENG, Jianqiang
 

Source
 


题目大意:
一个电梯运行时间的计算,电梯上升一层需要6秒,电梯下降一层需要4面在需要停止的楼层停留5秒,然后按照输入楼层的顺序依次将客人送到指定楼层,并计算出送完所有客人所需要的时间,送完后不需要返回楼底。输入的楼层数不能大于100
解题思路:
我的方法是利用了数组,将去往的楼层数按照输入的先后顺序依次存数组中,然后根据楼层上下关系,判断下一次运行时上升还是下降,并通过楼层差来统计时间,获得最终的总时间。将运行搞清楚就不是就不难。
#include<stdio.h>
#include<math.h>
int main()
{
	int i,n,count=0;
	int ceng[1000];
	while(scanf("%d",&n)&&n)
	{
		for(i=0;i<n;i++)
		{
			ceng[i]=0;
		}
		for(i=1;i<=n;i++)
		{
			scanf("%d",&ceng[i]);
			if(ceng[i]>=100) 
			{
				return 0;
			}	
		}
		count=5*n;
		for(i=0;i<n;i++)
		{
			if(ceng[i+1]>ceng[i])
			{
				count=count+6*(ceng[i+1]-ceng[i]);
			}
			else
			{
				count=count+4*(ceng[i]-ceng[i+1]);
			}
			
		}
		printf("%d\n",count);	
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值