Description
The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:
Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).
Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.
Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.
Sample Input
ababcababababcabab
aaaaa
Sample Output
2 4 9 18
1 2 3 4 5
题目大意:前缀和后缀匹配的长度有多少种,输出每种的长度,长度按升序排列
分析:这道题是想加深一下我们对next[]的理解,考虑到用如下算法得到next[]数组
void Build_next()
{
Next[1]=0;
int i=1,j=0;
while(i<N)
{
if (j==0 ||s[i]==s[j])Next[++i]=++j;
else j=Next[j];
}
}
则对于字符串ababcababababcabab来说next[]的值如下
下标 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 |
---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|
s | a | b | a | b | c | a | b | a | b | a | b | a | b | c | a | b | a | b | |
next[] | 0 | 1 | 1 | 2 | 3 | 1 | 2 | 3 | 4 | 5 | 4 | 5 | 4 | 5 | 6 | 7 | 8 | 9 | 10 |
在这里next[i]=j可理解为第i个字符前的(j-1)个字符所构成的字符串与第j个字符前的所有字符(也就是前j-1个字符)所构成的字符串匹配,现在观察next[19],next[19]=10,也就是说s[1…9]=s[10…18];所以长度为9是一个答案,现在在观察next[10]=5,也就是说s[1..4]=s[[6..9],刚才有s[1…9]=s[10…18],所以说next[1…4]=next[6…9]=next[15…18];所以长度为4也是一个答案,如此一直类推下去,直到回到达首字符为止,这里需要注意一下就是字符串本身的长度也是一个答案,这样所有的答案就都找到了,解题代码如下
#include <iostream>
#include <string.h>
#include <string>
using namespace std;
const int MAX_V=400005;
char s[MAX_V];
int Next[MAX_V],N,ans[MAX_V];
int Build_next()
{
Next[1]=0;
int i=1,j=0;
while(i<N)
{
if (j==0 ||s[i]==s[j])Next[++i]=++j;
else j=Next[j];
}
ans[0]=N-1;//字符串本身的长度也是一个答案
i=N;j=1;
while(Next[i]-1>0)
{
ans[j++]=Next[i]-1;
i=Next[i];
}
return j;
}
int main()
{
ios::sync_with_stdio(false);
//freopen("test.txt","r",stdin);
while(scanf("%s",s+1)!=EOF)
{
N=strlen(s+1);//从1开始
s[++N]='1';s[N+1]=0;//在字符串末尾任意添加一个字符,注意这里N变大了一位
int k=Build_next();
for(int i=k-1;i>=0;i--)cout<<ans[i]<<' ';
cout<<endl;
}
}